欢迎使用宏达产品

    欢迎使用宏达产品！快捷、方便、高效、强大，多种特色令您惊喜!!

    本帮助适用于使用《数据库信息管理开发平台》进行产品开发和对基于《平台》开发的产品进行二次开发的用户。基于平台开发的管理产品已经内置了开发平台的开发功能。

    宏达公司自主开发的《数据库信息管理开发平台》做为公司核心产品，在国内平台类产品中居于领先地位，操作简单，功能强大、容量小，对环境要求低，是真正的绿色软件构建平台。基于该平台开发的产品不计其数。拥有广泛的用户群体。宏达《数据库信息管理开发平台》具有如下特点：

    【快速构建基于数据库的信息管理应用】

    《数据库信息管理开发平台》被设计用来快速高效的构建基于数据库的各种信息管理系统，涵盖信息管理的采集、存储、查找、处理、输出、表现等完整过程，采用无代码开发方式，支持各种流行的小型、中型和大型数据库，适应于WINX全系列平台，是计算机管理应用中各个层次用户实施计算机辅助信息管理的最佳利器！

    【无代码高效快速开发】

    不需要编写程序，通过一些简单操作即可高效开发出灵活强大的信息管理系统。

    为了让各个层次的平台用户能够很好的来开发管理系统，平台提供了完整的无代码开发环境,开发者不需要编写一行代码就可以开发出功能强大的管理系统。

    平台提供了数量众多的设计器，让很多关键的功能实现只需要通过一些简单的操作就可以实现和维护。

    【涵盖单机和网络应用】

    单机应用方便灵活：平台开发的信息管理系统的单机应用，选用MDB数据库，MDB数据库是目前桌面数据库中最好用的数据库，选择该种数据库可以方便用户和其它系统进行数据共享和交换，而且便于维护和备份，当然，开发者也可以根据需要选择其它的数据库，因为平台是支持各种常见的数据库格式的，开发者可以根据需要灵活选择数据库格式。

    网络应用强劲支持：平台对网络数据库的支持表现在数据库无关性方面，您可以根据需要选择当前流行的各种大型数据库，根据我们的开发实践，宏达推荐选用微软的SQL SERVER数据库做为信息管理系统的数据库。平台专门针对该种数据库进行了优化，可以更好的发挥该种数据库的性能。

    单机应用和网络应用可以方便相互转换：开发者可以先以单机模式进行管理系统开发，在单机版本开发完成后，通过工具菜单下的“转换到新的数据库”功能，即可以方便的升迁到网络应用，基本不需要做任何修改。

    【支持多种流行数据库】

    支持面向桌面和大型数据库多种常见格式，方便用户和各种数据库格式数据进行交换和引用。

    数据库可以灵活选用：由于实际信息管理应用中经常会涉及到不同的数据库格式，为了更好的发挥管理系统的优势，有时候可能需要选择不同的数据库类型。平台最新版本采用数据库无关性设计，可以确保用户在需要的时候采用新的数据库格式，而不用重新进行开发，确保了用户的劳动成果。

    支持的数据库类型：平台支持对MDB、DBF、SQL SERVER、 SYSBASE、ORACLE等多种数据库。不同的数据库在一些具体细节应用方面可能有所不同，比如某些SQL语句的应用细节等请参考具体的数据库资料。

    【面向信息管理全过程】

    采用信息单元的概念管理信息流程：在平台中，信息单元是指一个相对完整的信息集合，涵盖了信息采集、信息存储、信息查找、信息输出、信息分析和信息计算处理六个环节。平台为每个环节提供了完整的支持，确保信息流程得到完整管理和体现。

    采用信息管理树的概念管理多个信息单元：在平台系统中，采用信息管理树管理信息单元，一个信息单元对应一个信息节点，可以同时包括信息表（或查询）、录入窗口、表格界面、报表、分析和计算处理等功能。

    多个信息节点构成信息管理树，信息管理树体现了信息管理系统的层次和构架，并引导用户更好的使用管理系统。

    【灵活性、智能性相互结合】

    平台和平台开发的系统支持多种数据信息交换方式、信息处理方式、易用的用户操作导航方式和信息展现方式，充分体现了系统的灵活性。系统同时自动具有日志功能、自动事务功能、系统构架自我分析生成文档功能，对当前信息可以自动根据内容分组查询功能等，体现了系统的智能性。充分发挥和利用系统的灵活性和智能性，并将二者有机结合，可以开发出功能强大且易用的信息管理系统。

    【适应WinX全系列平台】

    平台和平台开发的系统可以在Windows 98、Windows Me、Windows 2000、Windows XP、Windows 2003等操作系统上运行，适应性强。

    【纯绿色软件开发模式】

    平台及其开发软件都具有短小精悍的特点，为绿色软件，不会在系统中安装任何的DLL等文件，复制即可使用，符合当前绿色软件潮流。

    本帮助将分为三部分来引导用户学习数据库信息管理开发平台开发技能：

    基础应用：介绍平台系统的基本窗口和基本功能，属于应用范畴。

    开发教程：介绍一个简单的管理系统《中学成绩管理系统》的开发过程，增加用户利用平台开发系统的感性认识。

    系统开发：深入讲解平台的各个功能部分，使用户可以利用平台开发出功能强大的信息管理系统，使本帮助的主体部分。
宏达电脑服务中心　版权所有


系统主窗口

    系统主窗口可以分为三个区域：功能区、信息管理树和信息显示区。

    【功能区】

    功能区位于窗口的顶部，包括主菜单和工具栏。

    主菜单提供了开发平台的所有可用功能调用，开发者可以通过主菜单调用系统的开发功能和应用功能。

    主菜单一般以两种方式显示，“开发方式”和“应用方式”。开发方式显示时，信息管理系统的业务信息不出现在主菜单中，主菜单以如下形式显示：

    应用方式时，开发菜单被压缩到“系统”菜单中，其前均显示和具体的信息管理系统相关的业务菜单：

    业务菜单根据开发的系统的信息管理树自动生成，可以通过菜单功能“视图－建立撤销菜单化管理”来使菜单显示在“开发方式”和“应用方式”之间转换。

    工具栏提供了常用功能的快捷调用方式。工具栏具有两种显示方式，“简约显示”和“完整显示”s。

    简约显示：提供信息管理系统使用的常用功能按钮。这些功能属于应用功能，实现用户对管理信息的一般操作，如：打开录入窗口、报表，对当前信息进行筛选查询等。

    完整显示：提供简约显示和包括开发功能在内的完整的主要功能调用。

    通过“显示/隐藏设计”按钮 [image] 可以方便的在两种显示形式之间转换。

    工具栏各按钮的名称及其功能描述见下表：

控件 按钮 | 名 称 | 功 能
 | 隐藏显示信息管理树 | 显示或者隐藏信息管理树的逻辑按钮。
 | 打开录入窗口 | 打开当前信息节点关联的信息单元的录入窗口。
 | 打开报表 | 打开当前信息节点关联的信息单元的报表。
 | 打开信息分析 | 打开当前信息节点关联的信息单元的信息分析窗口。
 | 显示隐藏命令面板 | 显示或者隐藏浮动命令面板和背景命令面板（等效快捷键F8、F9）。
 | 表格打印预览 | 针对当前的表格界面生成报表格式并预览，可以保存该报表格式以便进一步修改和使用。
( [image] ) | 显示隐藏设计按钮 | 显示或者隐藏主窗口工具栏上的开发按钮，使工具栏在简约显示和完整显示两种方式间转换。
 |  |  | 单步累积查询 | 单步查询，下一步的查询是在上一步的基础上进行的，如果希望重新查询，单击取消筛选按钮。
 | 复合筛选 | 创建复合查询条件的筛选查询。
 | 取消筛选 | 取消当前已经设置的查询条件。
 | 刷新数据源 | 从新打开当前数据源，一般是重新刷新当前信息节点的全部信息单元。
 | 取消排序 | 取消当前通过单击表格界面字段标题而设置的排序方式，非实表访问方式时有效。
 | 输入法选择 | 选择输入法，选择的输入法将在系统中被默认的使用，直到被用户改变。
 | 记录筛选设置 | 对主表进行记录筛选设置，设置可以被保存并在以后通过表格界面下方的第一个下拉列表调用。
 | 字段筛选设置 | 对主表进行字段筛选设置，设置可以被保存并在以后通过表格界面下方的第二个下拉列表调用。
 | 表格界面设置 | 对当前信息节点的主表和从表的表格界面显示属性进行设置。
 | 表格辅助录入 | 设置当前主表的辅助录入特性。
 | 记录计算与验证 | 设置当前主表的基于记录级别的字段之间的计算和验证公式。
 | 字段批量计算 | 设置字段间的计算公式，设置可以保存并在以后通过表格界面下方的第三个下拉列表调用。
 | 设计录入窗口 | 打开录入窗口设计界面，对当前录入窗口进行设计。
 | 修改报表格式 | 打开报表设计界面，对当前报表进行设计。
 | 信息表设计器 | 打开信息表设计器，创建和设计信息表。
 | 运算树 | 打开运算树，设计面向整个系统的SQL语句处理过程。
 | 菜单转换按钮 | 让主菜单在显示和隐藏业务菜单（应用方式和开发方式显示）之间进行转换。

    【信息管理树】

    很多情况下，信息单元并不是单独出现的，一个系统往往包含了很多信息单元，为了更好的管理各个单元的信息流程和信息单元之间的相互作用，数据库信息管理开发平台使用了“信息管理树”来管理各个信息单元。

    信息管理树一般由两种节点构成：信息节点和类节点。信息节点直接关联信息单元，类节点一般不直接关联信息单元，而是用来包含信息节点，体现信息管理系统管理内容的类别或层次。

    该区域还包括录入窗口、报表输出和信息分析等小区，这些小区总是显示当前被选中的节点包含的录入窗口、报表和分析图形。

    该区域上的鼠标右键弹出菜单经常会使用到，用来创建信息管理树和各个节点的各种属性。

    通过工具栏“隐藏/显示信息管理树”按钮 [image] 可以方便的关闭和打开信息管理树。

    【信息显示区】

    信息显示区用来显示信息管理树当前信息节点所关联的信息单元的内容。

    一般情况下，信息是以表格的方式显示的，可以对信息进行基本的输入和维护，也可以进行各种查询。如果当前信息单元关联多个表，则这些表以主从表的方式显示，上面的为主表（唯一），下面的为从表（一个或多个），一般情况下从表的记录随主表记录的变化而变化。

    如果当前节点关联的是非数据库信息，例如网页地址，该区域用来显示网页信息，网页信息可以被设置成某些特殊的连接信息以便实现对系统功能的调用，浮动背景命令面板就是基于这种技术实现的。

    如果当前的信息节点设置了关于节点功能的文字说明，这些说明将会显示在窗口的最下方。


信息管理树

    信息管理树位于系统主窗口的左侧，提供管理系统的业务构架和功能调用。可以说信息管理树是管理系统的主干，它和其它的一些辅助功能构成了系统的主体。

    【类节点和信息节点】

    信息管理树由节点分层次构成，节点分为类节点和信息节点。类节点的图标为 [image] ，类节点一般用于对信息节点进行分类，信息节点的图标为 [image] ，信息节点一般做为类节点的子节点，信息节点和业务数据关联，和描述业务的表格界面、录入窗口、报表、信息分析有对应关系。

    如果某个信息节点已经关联数据源，单击该信息节点即可打开信息节点对应的表格界面。

    在信息管理树下方分别显示当前节点对应的录入窗口列表、报表列表和信息分析列表。分别双击各个列表的标题可以打开对应的项目。

    如果希望对录入窗口、报表、分析等进行调整以满足应用需要，请使用各自的鼠标右键弹出菜单。

    单击工具栏的“隐藏显示信息管理树”按钮 [image] 可以隐藏和显示信息管理树。

    信息管理树的节点及其层次和业务菜单一一对应，也可以通过业务菜单访问节点的对应内容。

    关于每个弹出菜单项的功能说明，请参考本帮助后面的内容。


表格界面说明

    表格界面根据当前选定节点指定的连接数据源，以表格的形式显示信息内容，如果信息节点同时包含主表和从表，则表格界面分为上下两部分，分别显示主表和从表，如果有多个从表，则从表部分以多页控件的方式显示多个从表，可以通过单击相应的按钮选择查看相应的从表。

    表格界面除了有表格显示数据外，还有配套的记录导航按钮，通过导航按钮可以控制记录的移动。

    【记录导航条】

    通过记录导航条可以对记录进行移动、插入、删除、修改、保存、取消修改等操作。

控件 按钮 | 名 称 | 功 能
 | 第一条记录 | 移动记录指针到第一条记录
 | 一条记录 | 移动记录指针到上一条记录
 | 下一条记录 | 移动记录指针到下一条记录
 | 最后一条记录 | 移动记录指针到最后一条记录
 | 插入记录按钮 | 在当前记录前面加入一条新记录
 | 删除记录按钮 | 删除当前记录
 | 编辑记录按钮 | 使当前记录处于编辑状态
 | 保存记录按钮 | 保存当前记录的修改
 | 撤销修改按钮 | 撤销对当前记录的修改

    一般情况下，可以直接对表格内的数据进行追加和维护，除非设置了只读。

    通过工具栏的查询功能可以实现对表格数据（主表数据）进行查询，查询分为两种：单步累积查询和复合查询。

    【单步累积查询】

    “条件字段”下拉列表、“条件运算符”下拉列表、“条件值”下拉列表和“执行筛选”按钮组成单步累积查询。在这里，“单步”是指查询是一步一步的设置的，每次查询只能设置一个条件；“累积”是指查询设置的条件是累积有效的也就是说在执行新的查询时，截至到上步设置的查询条件都是有效的，而且与本步设置的条件共同起作用，二者是“并且(AND)”的关系。

    选中一个连接数据源的节点后，表格界面就会显示对应的数据源信息。在条件字段下拉列表中会自动包含当前数据源的所有的字段名称列表；在条件值字段中可以选择“=”“>”“>=”“<”“<=”“Like”等项目，在“条件值下拉列表”中可以输入条件值或者选择系统提供的条件值。然后点击“执行筛选”按钮，即可执行由这三个列表框选定或者输入的内容构成的条件表达式所构成的查询，查询的结果会直接在表格界面显示。

    因为这种查询是累积有效的，如果你希望从新开始查询，请单击后面的“取消筛选”按钮。

    【复合查询(筛选)】

    很多情况下希望一步得到多个条件复合在一起的查询，这种情况下使用复合查询，单击主窗口工具栏上的“复合筛选”按钮 [image] ，进入复合筛选窗口。

    在该窗口可以通过四个下拉列表框来构建筛选条件，条件字段下拉列表、运算符下拉列表和条件值下拉列表可上面的单步累积查询功能相同，后续选项用来确定是否还有后续条件设置。每步条件设置完毕后通过单击“添加到筛选条件”按钮添加到筛选条件区域。多步条件设置完毕后通过“应用筛选”按钮完成本次筛选，系统会对表格界面当前的数据源（主表）进行筛选，然后显示筛选后的数据。

    【表格界面右键弹出菜单】

    利用表格界面右键菜单可以更方便的使用表格界面的信息。

    右键菜单可以实现如果功能：

      一、根据当前表格生成报表，并且可以预览、打印输出和保存修改。

      二、对表格显示列（字段）进行临时筛选，以便更好的显示数据信息或打印输出。

      三、执行和取消复合临时筛选

      四、刷新数据源和取消有单击字段标题而形成的字段排序。


录入窗口

    录入窗口被设计用来做为信息表或其查询的输入更新界面。通过录入窗口对信息进行维护，可以确保信息更直观的显示和编辑，对于图像管理、OLE控件管理，只能通过录入窗口实现，录入窗口提供了对日期类型数据的选择录入格式。提供了辅助录入功能，可以在很多情况下实现高效录入。一个专业的信息管理系统应该设计录入窗口，以方便用户更好的使用信息管理系统。

    如果信息管理树当前节点已经设置了录入窗口，在主窗口工具栏上单击“录入窗口”按钮 [image] ，即可打开录入窗口进行数据信息维护操作。

    录入窗口分为三部分：信息录入区辅助录入区和工具栏。

    【信息录入区】

    信息录入区放置各种和业务信息相关的项目，可以录入和修改。可以通过TAB键（或回车键）和鼠标键来实现在各个信息项目之间进行转换。

    信息项目有编辑框、下拉框、备注框、日历下拉框、和图形控件几类。

    编辑框：可以直接录入和修改，最为常用。

    下拉框：可以通过鼠标选择固定的输入项目，如果上图的“性别”信息项目，因为输入内容只能是“男”或“女”，因此采用下拉框。

    备注框：用来输入大段的文字信息，例如简历信息等。

    日历下拉框：针对日期格式的输入，单击下拉框后，会出现一个日历选择对话框，可以实现鼠标日期数据输入。

    图形控件：用来存储图形信息，通过鼠标左键单击鼠标可以存储图像，右键单击可以导出图像。

    【辅助录入区】

    有时很多需要录入的信息系统中已经输入过，通过辅助录入可以将已经存在的信息供用户选用，待选用的信息在辅助录入区中显示。

    当录入区中设定辅助录入的项目获得焦输入点时，辅助录入区中就会显示对应的待选项目，可以通过鼠标选择希望输入的项目，从而提高输入效率和准确率。如果上图中，“班级”信息项目是辅助录入的，当其获得焦点时，辅助录入区中自动显示了待选项目，用鼠标点选即可实现录入。

    如果整个录入窗口中没有设定辅助录入的项目，辅助录入区不会显示。

    【工具栏】

    工具栏主要实现如下功能：记录导航，记录保存、增加和删除，调用对应报表输出，填充式查询，数据源刷新。

控件 按钮 | 名 称 | 功 能
 | 第一条记录 | 移动记录指针到第一条记录
 | 一条记录 | 移动记录指针到上一条记录
 | 下一条记录 | 移动记录指针到下一条记录
 | 最后一条记录 | 移动记录指针到最后一条记录
 | 插入记录按钮 | 在当前记录前面加入一条新记录
 | 删除记录按钮 | 删除当前记录
 | 编辑记录按钮 | 使当前记录处于编辑状态
 | 保存记录按钮 | 保存当前记录的修改
 | 撤销修改按钮 | 撤销对当前记录的修改
 | 追加记录按钮 | 在记录的最后追加新的记录
 | 报表预览 | 打开默认报表的预览界面
 | 报表打印 | 直接将当前默认报表内容进行打印，不显示报表预览界面
 | 启动查询 | 启动填充式查询
 | 执行查询 | 执行填充式查询
 | 刷新数据源 | 重新打开当前节点数据源

    填充式查询：用来实现在录入窗口通过在对应项目中输入希望查询的示例数值，由系统自动实现匹配的查询。单击启动查询按钮 [image] ，录入窗口的各个信息项目均空白显示，然后在某些项目中输入希望查询的信息值，然后单击执行查询按钮 [image] ，录入窗口就会只显示复合条件的记录，可以对这些记录内容进行各种操作了。


报表输出

    报表被设计用来做为信息表或其查询的输出打印界面，一个专业的信息管理系统应该有功能完整操作方便的报表输出操作窗口，以方便用户更好的使用信息管理系统。

    如果信息管理树当前节点已经设置了报表，在主窗口工具栏上单击“打开报表”按钮 [image] ，即可打开报表预览和打印窗口进行信息打印操作。

    报表窗口分为两部分：工具栏和报表显示区。

    【报表显示区】

    报表显示区显示根据报表格式和当前信息源内容而生成的报表样式，该样式和打印机输出格式完全相同。

    【工具栏】

    工具栏主要实现如下功能：报表格式显示控制，打印打印控制，报表导出。

控件 按钮 | 名 称 | 功 能
 | 页面高度显示 | 按页面的高度显示
 | 页面宽度显示 | 按页面的宽度显示
 | 实际大小显示 | 按页面的实际显示
 | 页面大小调节 | 调整页面按照指定比例显示
 | 打印机属性设置 | 设置打印机的属性，包括输出到的打印机和打印页码、打印份数等。
 | 打印输出 | 将显示内容输出到打印机
 | 生成图形 | 将当前页码生成图形格式文件
 | 第一页 | 显示报表的第一页
 | 上一页 | 显示报表的上一页
 | 下一页 | 在显示报表的下一页
 | 最后一页 | 显示报表的最后一页
 | 报表导出 | 将报表显示内容以指定的格式输出，包括：文本格式，HTML格式和CSV格式


信息分析

    系统的信息分析窗口用来对当前信息节点所关联的数据源以各种分析图形的方式进行展示，方便用户参考和管理。

    如果当前信息节点已经设计信息分析，在主窗口工具栏单击“信息分析”按钮 [image] ，即可进入信息分析窗口。

    信息分析窗口基本分为两部分：工具栏和图形显示区。

  【图形显示区】

    图形显示区显示根据数据源生成的图形分析样式。

    一般情况下，图形显示区总是根据窗口的大小自动适应，可以通过改变窗口的大小改变分析图形的大小。

    使用鼠标左键单击后向右下方向拖拽会形成一个矩形区域，该区域会被放大到充满图形显示区显示；如果向左上方向拖拽，显示图形会恢复到原来大小。使用鼠标右键按住拖拽会移动显示区域。

    分析图形可以设置标题、图例、显示风格、坐标信息等，这些功能都是通过分析设置按钮 [image] 进行设置。

    【工具栏】

    工具栏主要实现如下功能：清空当前信息分析图形、重新读入信息分析设置、信息分析设置、信息分析设置保存和信息分析图形打印输出。

控件 按钮 | 名 称 | 功 能
 | 新建图形 | 创建新的分析图形，原有的分析图形如果存在则被清除。
 | 打开图形 | 重新读入已经保存的分析设置信息，如果已经修改，在修改会被放弃。
 | 分析设置 | 进行具体的分析设置，参见系统开发部分的“信息分析设置”说明。
 | 保存设置 | 将当前的信息分析设置信息保存。
 | 分析打印 | 将当前的分析图形输出到打印机。


数据处理

    如果系统设计了数据处理，就会在主窗口系统菜单上出现“数据处理”菜单主项目。

    通过执行对应可以完成一定的信息汇总等功能。

    可以通过主菜单：“工具－运算树增强处理”来对数据处理进行设置和修改，具体操作参见系统开发部分。


数据备份和恢复

    数据备份和恢复功能用于单机系统的备份，备份内容包括系统设置信息和系统业务数据信息。如果用户对系统做了二次开发，所有的二次开发信息也会一起备份。

    【进入数据备份和恢复窗口】

    通过执行主窗口主菜单：“工具－数据备份与恢复”可以进入数据备份和恢复窗口：

    【窗口功能说明】

    备份列表：显示在系统文件夹下的backup子文件夹中依据备份的列表。

    备份当前数据按钮：将当前系统数据备份，自动备份到backup文件夹，如果当天已经备份过，则弹出保存对话框请用户指定名字。

    恢复选定备份按钮：将备份列表中选定的备份文件恢复到当前系统中，如果当前系统中有备份后新增加的数据，将会丢失。

    清除选定备份按钮：将备份列表中选定的备份文件清除（删除）。

    备份数据至...按钮：将当前系统数据备份到一个指定的路径，比如软盘、优盘等。

    从...恢复备份按钮：从指定的路径恢复数据到系统，如果当前系统中有备份后新增加的数据，将会丢失。


权限设置

    用户可以选择用户权限设置是否启用，如果没有启动权限机制，用户默认以超级用户Admin的身份进入系统。如果启用，用户在登录时就会显示登录窗口，并根据授予的权限确定做什么样的操作。只有超级用户才能进行权限设置，可以创建用户和分配权限。也只有超级用户才拥有系统二次开发权限。

    【进入用户权限设置窗口】

    在系统主窗口，执行主菜单：“工具－用户权限设置”可以进入权限设置窗口。

    启动权限管理按钮：通过执行该按钮启动权限管理机制，权限管理机制启动后，该按钮自动显示为灰色（不可用）。

    撤销权限管理按钮：通过执行该按钮撤销权限管理机制，权限管理机制撤销后，该按钮自动显示为灰色（不可用）。

    操作者：选择进行权限设置的用户名称。Admin为超级用户，总是存在不能被删除。选择某个用户后可以对齐进行口令设置和设置权限。

    新建按钮：创建新的用户，需要指定用户的名称。

    删除按钮：删除当前选定的用户。

    复制按钮：根据当前用户的权限设置创建新的用户。

    口令设置：对当前用户进行口令设置，需要依次输入：当前口令、新口令、确认输入重新输入新口令，然后单击“修改”按钮即可完成口令修改。

    权限：包括针对每个节点的各种信息单元元素的访问权限设置和数据处理的权限设置。

    节点相关：包括当前（节点）信息可见、表格界面可见、表格界面只读、录入窗口可用、录入窗口只读、报表可用、图形分析可用、图形分析可以设计等。在选定指定节点后，再根据需要在对应的权限选项前面根据需要选定或取消选定即可。

    数据处理，包括：数据处理可用和数据处理可以修改两个选项。

    应用权限按钮：在对当前用户进行权限设置后，必须执行该按钮才能将信息保存并其作用。


信息库压缩

    为了保证系统效率和实现共享机制，对系统数据的某些操作（例如删除、信息表结构修改等）产生的无用数据并不是及时删除，这样在长期操作后，信息库文件会变的比较大。为了清除这些数据，用户可以使用信息库压缩功能，清除这些无用数据，确保信息库只存放有效数据且保证较小体积。

    在主窗口通过执行主菜单：“工具－信息库压缩”可以执行该功能。

    如果当前系统只有当前用户使用，系统会成功压缩并重新进入系统，反之会提示其他用户正在使用，建议用户在确定是单人使用时在使用该功能。

    该功能只是针对单机系统或者文件共享方式使用的系统有效，不适用与C/S结构的系统。


操作日志

    系统的操作日志用来跟踪用户对应用系统的各种数据操作和使用情况。如果希望使用日志功能，需要在选项中进行设置，以启动系统的日志跟踪功能。

    【日志设置】

    在主窗口，通过执行菜单：工具－选项，即可进入选项设置窗口，选择“日志设置”页。

    【日志记录项目设置】

    可以根据系统的应用情况和希望跟踪的目标，灵活设置日志记录项目。系统支持的项目如下：

    系统登录和退出，信息节点访问，信息增删和修改，录入窗口、报表和信息分析，数据处理菜单调用，SQL命令窗口的使用。

    在需要记录的项目上选中即可，然后确定退出，系统即启动日志记录功能。

    【日志查看器】

    可在日志查看器中查看日志记录信息，在主窗口，通过菜单：工具－日志查看器可以打开日志查看器窗口，如下图：

    该窗口功能说明如下：

    【日志查看筛选设置】对日志信息进行筛选设置：

    期间：指定显示的日志记录的期间。

    操作者：指定显示的日志记录的某个操作的信息，如果不选择则默认为所有操作者（用户）。

    操作类型：指定显示的日志记录只包含选定的日志项目。

    查看选定节点日志项目：如果该项选定，则只有当前信息节点且复合前面设置的日志信息才会显示。

    【查看筛选日志按钮】　根据上面的设置，显示指定的日志记录信息。

    【查看全部日志按钮】　上面的筛选设置无效，显示全部的日志记录信息。

    【清除当前日志按钮】　清除当前显示的日志，如果当前日志是筛选后的结果，则只有筛选的这些记录被清除。

    【清除全部日志按钮】　清除系统记录的所有日志。

    窗口的下半部分显示日志的记录信息，包括时间、操作者、操作和项目信息，如果涉及到数据增删修改，会在最下面的编辑框中显示修改前后的内容对比，在SQL命令窗口执行的SQL语句也会显示在这个编辑框中。

    通过数据导航栏可以翻看前后的相关日志记录。


使用快捷键

    为了方便用户操作，系统对一些常用功能设置了快捷键，可以通过快捷键方便的调用这些系统功能，以下是快捷键功能列表：

快捷键 | 功能说明 | 适用条件
F1 | 调用系统二次开发帮助文件 | 系统主窗口
F2 | 调用管理系统的业务帮助文件 | 系统主窗口
F8 | 显示和隐藏浮动命令面板 | 系统主窗口
F9 | 显示和隐藏背景命令面板 | 系统主窗口
F10 | 调用菜单 | 系统主窗口
Shift(左)按下时增加记录 | 将当前记录内容复制到新增加的空白记录中 | 表格界面，录入窗口


快速开发《中学成绩管理系统》

    本教程带领大家快速开发一个完整的信息管理系统，以带领大家进入数据库信息管理开发平台的殿堂。示例系统《中学成绩管理系统》已经随开发平台提供，系统假设为应用于中学的成绩管理。

    【准备】

    教程假设您已经安装了宏达《数据库信息管理开发平台》，并且已经进入该系统。

    【创建信息库(管理系统)】

    在系统主菜单中点击：文件→新建信息库，然后在弹出的对话中录入系统名称如：中学成绩管理系统，如果当前文件夹中已经存在相同的名字，可以用其它类似的名字，例如：中学成绩管理，平台会自动创建一个空的系统，供用户开始构建和设计。


创建信息表和管理树

    【利用信息表编辑器创建信息表】

通过系统菜单：工具→信息表编辑器，可以打开信息表编辑器，信息表顾名思义，利用信息表编辑器可以创建和修改需要的信息表的结构，信息表支持各种常见的数据类型按照下面的图示创建信息表，信息表名次为“成绩信息表”：

    输入和上面完全一致的内容，然后点击确定按钮，如果系统出现不能成功创建的提示，请参照上面的图形和你输入的内容进行核对，系统会出现“结构修改成功”的提示。

    【创建信息管理树】

    在信息管理区单击鼠标右键，可以弹出右键菜单，利用插入节点功能创建类节点和子类节点。

创建完毕后，用鼠标右键单击节点或类节点选择节点改名，然后录入节点的名字。修改完毕后如图所示：

    【信息节点关联数据源】

    将节点和具体的--业务内容关联起来（设置数据源/表）此节点内容将在第三章中进行详细介绍。

我们就以“名单录入”节点为例：

通过在“名单录入”节点单击鼠标右键弹出快捷菜单，通过菜单“信息关联设置-设置信息表源)”即可打开设置窗口：

在使用数据表中的右边的下拉列表中选择关联的表：成绩信息表。


使用SQL语句

在本小节中我们将通过实例的讲解来介绍一些简单的SQL语句，详细的SQL语句我们将在其它章节中进行详细介绍。

在本示例中有些节点需要使用SQL语句，例如“语文”节点需要使用如下语句：

SELECT ID,班级,学号,学籍号,入学时间,姓名,性别,语文 FROM 成绩信息表

    ORDER　BY 班级,学号

其他节点的SQL语句也是如此，只是把语文换成相应的科目。如图所示：

(图1-6)

查询类节点需要使用复杂一些的SQL语句：

成绩名次：SELECT 班级,学号,学籍号,姓名,性别,总分,(SELECT COUNT(*)+1 AS名次 FROM 成绩信息表 AS A WHERE A.班级 = 成绩信息表.班级 AND A.总分 > 成绩信息表.总分) AS 班级名次, 语文,数学,英语,政治,物理, 化学,历史,地理,生物,音乐,体育 FROM 成绩信息表

单人查询：SELECT 班级,学号,学籍号,姓名,性别,总分,(SELECT COUNT(*)+1 AS

名次 FROM 成绩信息表 AS A WHERE A.班级 = 成绩信息表.班级 AND化学,历史,地理,生物,音乐,体育 FROM 成绩信息表 WHERE 姓名 LIKE :请输入姓名 & '%'

    班级查询：SELECT 班级,学号,学籍号,姓名,性别,总分,(SELECT COUNT(*)+1 AS 名次 FROM 成绩信息表 AS A WHERE A.班级 = 成绩信息表.班级 AND A.总分>成绩信息表.总分) AS 班级名次, 语文,数学,英语,政治,物理,化学,历史,地理,生物,音乐,体育 FROM 成绩信息表 WHERE 班级 = :请输入班级名称

班级平均成绩：SELECT 成绩信息表.班级, AVG(成绩信息表.总分) AS 平均总分 FROM 成绩信息表 GROUP BY 成绩信息表.班级

对各科成绩录入完后，可通过触发器的功能自动统计出总分.如：“各科综合录入”在这个表中录入完各科成绩后关闭这个节点，然后再打开这个节点总分就会自己统计出来。选中各科综合录入这个节点右键→信息关联设置→触发器设置，可打开如图：


设计录入窗口

    本小节主要讲解录入窗口的制作和报表的设计(其详细内容见第五、六章)。下面是学生名单录入窗口设计。

    首先我们选中“名单录入”这个节点，单击鼠标的右键会出现这一菜单，在快捷菜单中选择“录入窗口”→“新建录入窗口”，这时弹出一个对话框让我们输入名称，在这里我们输入“学生名单录入”。点击“OK”进入设计窗口。

    在工具栏中选择“版面设置”按钮 [image] 出现“录入面板设置”在这里可以导入在录入窗口中要出现的字段。然后在进行设计。

    请按照窗口进行设置，然后点击“开始导入”按钮，然后点击“确定”按钮。

    通过录入窗口设计窗口上面的标签控件增加标题，具体操作为点击标签按钮 [image] ，然后在放置标题的区域点击，就会创建一个标签，然后通过右边最上面的标题属性设置为“学生名单录入”，并在右边找到“字体”按钮，设置字体到合适的大小，如果某些控件位置不合适，可以通过鼠标拖拽调整。最终如下：

    单击保存按钮退出，完成录入窗口设计。


设计报表

现在我们为成绩查询－成绩名次这个节点设置报表，单击该节点，使其选定。单击工具栏图标： ,系统自动根据信息内容生产报表，如图：

单击保存按钮，根据系统提示即可将当前格式保存。

在节点“成绩名次”上单击鼠标右键，在弹出菜单上选择：报表输出－报表修改，进入报表设计窗口。在这里可以对报表格式进行修改，和录入窗口设计类似，可以修改标题等。最终格式类似如下图：


设计信息分析

下面介绍创建成绩分析图形：

鼠标右键单击“班级平均成绩”节点，在弹出菜单中选择－“信息分析”－“创建信息分析”，系统弹出信息框要求为分析确定一个名称，输入名称：“各班级平均总分分析”，确定后，系统出现一个“信息分析图形”窗口。

单击“图形编辑”按钮 [image] ，系统弹出图形编辑对话框。

单击选择“指定数列图形类型”下面的下拉框，选择一个适合自己的图形样式，这里以柱状图形为例：单击选中“立体图形”，这样建立的图形很形象、有立体感。再单击“增加数列图形”按钮，给数列起个名称“平均总分”。

选中“平均总分”这个数列，选择上面的“数列”选项卡，再选择后面的“数据”选项卡，在纵向赋值下面定义在柱状图上显示的数据，在标志下面选择“班级”，在Y坐标值下面选择“平均总分”，然后“应用到数列图形”，此时分析图的雏形已经出来了，以下的工作就是进行美化界面，使界面更直观一些。

在“柱图格式”选项卡下面，选择一个自己认为合适的风格图形“斜矩形”，把“颜色不同”选中，使界面更美观一些；

选择“图形”选项卡，再选择“标题”选项卡，把“图形分析”修改成“2004各班级平均总分分析：”，单击“字体”按钮，设字号四号；对齐方式请选择“左对齐”；

再选择“面板”选项卡，“可见”前打上对号，开始颜色选择：白色，结束颜色选择：深蓝色，方向选择：中心扩散，这些都是进行美化界面的操作。

    最后保存退出即可。


创建命令面板

创建命令面板，可以方便最终用户操作平台开发的信息管理系统，让系统更贴近用户，更具有亲和力。用户直接操作命令面板就可以完成系统的操作。

通过菜单：工具－设计操作向导，可以进入命令面板设计窗口。

单击“启动命令面板”，后“确定”，按照系统需求分析，我们可以设定三个命令面板，一个主面板，两个子面板，单击“创建命令面板”按钮，输入“主面板”后，“OK”；按照这个步骤再连续创建两个子面板，分别命名“成绩录入”、“成绩查询”。

    单击选中“主面板”，再单击“设定为主面板”按钮，目的是一进系统，先出现主面板，后单击“设计选定面板”，在弹出的窗口中，单击工具栏上的“背景图形”控件，会弹出一个对话框，在对话框中，选择事先做好的命令面板的图片（这里选择了系统附带的图片，开发者可以根据自己的情况使用图形工具自己设计图片），打开后，在空白处就显示出了图片。

    单击工具栏上的“功能区”控件 [image] ，此控件为浮动的按钮，把此控件放在合适的位置，调整好它的宽度和长度，把第一个功能按钮，放在了名单录入上面，单击左边信息树上的“名单录入”节点，再选择下面操作里面的录入窗口，并在下面选中录入窗口的名称。对命令面板操作时，若单击“名单录入”上面的按钮，就会直接进入名单录入的录入窗口。

再创建一个功能区，放在“成绩录入”上面的，调整好长度和宽度，后选中左边“功能”单选框里面“面板”选项，并在其下面下拉框中选择“成绩录入”面板。

  创建一个功能区，放在“成绩查询”上面，操作同“成绩录入”，不同的是选择“成绩查询”面板。

  创建一个功能区，放在“成绩分析”上面，调整好长度和宽度，单击选中操作下面的“信息分析”，再单击下拉框选择“各班级平均总分分析”。

  设计“成绩录入”和“成绩查询”面板的操作同上，只是有个不同的是返回到主面板的按钮，创建一个功能区，放在“返回”箭头上，选中功能中的“面板”，再选择“主面板”。


快速构建基于数据库的信息管理应用

    《数据库信息管理开发平台》被设计用来快速高效的构建基于数据库的各种信息管理系统，涵盖信息管理的完整过程，采用无代码开发方式，支持各种流行的数据库，适应于WINX全系列平台，是计算机各个层次用户实施计算机辅助信息管理的最佳利器！

    【信息单元】

    信息单元是指一个相对完整的信息集合，它对应一个信息表（数据库）或一个查询。一般情况下，一个信息单元的管理涉及信息的采集、存储、计算处理、显示、输出和分析等方面，针对这些环节，数据库信息管理开发平台提供了相应的功能来实现这些环节的信息处理，用户只要构建了这些功能模块，就完整的体现和管理了一个信息单元整个流程。

    下图为数据库信息管理开发平台的各个功能模块和一个信息单元流程的对应关系，括弧中的为平台的功能模块。

信息单元流程和平台功能对应关系

    从上图可以看出，一个信息单元的完整流程可以通过数据库信息管理开发平台的录入窗口、信息表、信息处理、表格界面、报表和信息分析来完整提现。

    【信息管理树】

    因为很多情况下，信息单元并不是单独出现的，一个系统往往包括了很多信息单元，为了更好的管理各个单元的信息流程和信息单元之间的相互作用，数据库信息管理开发平台使用了“信息管理树”来管理各个信息单元，信息管理树的节点对应着一个信息单元或者信息单元的结合体（比如设计多个信息表的查询），也就是说一个节点管理了一个信息单元的信息表（或查询语句）、录入窗口、表格界面、报表、分析和处理等。如下图所示：

信息管理树节点和信息单元一一对应

    一般情况下，信息类节点用于将信息单元归类，并不包含信息单元。

    数据库信息管理开发平台利用信息管理树来管理各个信息单元，一般情况下，一个信息节点对应一个信息单元，信息单元可以包括：信息表、录入窗口、表格界面、报表、分析和处理，这些功能模块并不是必须的，开发者根据管理需要可以增删。很多情况下不需要信息采集（录入）的信息单元对应的信息节点的信息表被使用查询替换。

    信息管理树本身也是信息管理系统管理信息的构成体现，具有描述管理业务的功能和层次的意义。

    【信息处理】

    这里的信息处理是指信息计算处理，平台支持多种信息处理方式，可以在一个节点上对信息进行计算处理（公式、SQL语句、触发器等），也可以利用“运算树信息增强处理”功能来实现信息表之间的相互运算处理。信息处理经常在多个信息表间进行。

信息处理经常在多个信息表间进行

    【利用<数据库信息管理开发平台>开发管理系统的基本步骤】

    在一般的信息管理系统中需要设计多个信息表，在实际开发实践中，信息表的设计并不是逐个信息单元来设计的，而是要根据管理系统的综合需求来整体设计，以保证系统信息管理的完整和高效。利用数据库信息管理开发平台开发管理系统基本包括如下内容：

1、构造信息表 | 根据管理需求，对业务信息进行分类，确定一个或者多个信息单元，对信息单元包含的信息细化，每个不可分割的信息元素做为信息表的字段，同时确定字段的类型和长度等属性。然后在此基础上利用“信息表编辑器”构造信息表。
2、创建信息管理树 | 根据业务层次或者内容分类创建信息管理树，并对具体的节点连接数据表或查询，实现表格界面及其查询功能。
3、数据处理 | 如果系统需要对数据进行处理，建议进行数据处理设计，因为根据处理的需要有可能需要对信息表结构进行修正。
4、设计录入窗口 | 针对含有数据录入功能的节点设计录入窗口，为系统用户提供录入界面。
5、报表输出 | 根据业务需要针对节点设计报表，便于将处理或查询的信息打印输出。
6、信息分析 | 根据分析需要设计针对节点的信息分析。
7、操作向导 | 为了便于最终用户使用，可以创建命令面板或者背景界面，以方便用户理解系统和高效使用管理系统。
8、其它方面 | 闪屏、帮助文件、背景、手册等辅助部分。
9、制作安装程序 | 便于用户安装和使用

    因为系统是快速开发的，所以这里没有将系统测试做为一个单独的步骤提出，开发者可以在任何一个环节将产品提供给用户试用和根据用户反馈修正系统。


信息表基础

    创建信息表的实质就是定义表的结构，信息表可以最直观的反应出表中的内容。它是用来存储和操作数据的一种逻辑结构。表由行和列构成，因此也称之为二维表。表是在日常生活和工作中经常用到的一种表示数据及其关系的形式。
1.表的结构
定义表中的字段，就是要确定表的结构，即确定表中字段的名称、类型、属性、说明等。
（1）字段名称
字段是表的基本存储单元，是同类型数据的标识符，为字段命名可以方便地使用和识别字段，使操作更方便，快捷。
（2）字段的数据类型
在信息表编辑器中有序号，字段名称，类型，长度四个字段。
1）序号：可能输入整数或使用小数，来进行排序。在插入记录时，要把插入的记录的数字设为输入两条记录间的小数。
2）字段名称：用来输入你所要建立的字段的名字。
字段名称定义的一些基本规则如下：
1．名称通常是由字母，汉字，数字或下划线组成，但是名称的第一个字符必须是字母或汉字。
    2．名称的长度不能超过255个字符。
（3）类型：用来选择你所输入数据的类型。
类型定义中的一些基本规则
（1）“文本”类型：用来输入文本或文本与数字的组合。但是要注意设置长度，在输入时注意不要超长，最长为255个字符。因为超长部分将不被保存。
        （2）“整型数字”类型：可以输入任意常规整型数字。
        （3）“精度数字”类型：可以输入任意常规整型和小数数字。
        （2）“备注”类型：用来输入长文本或文本与备注的组合。最长长度为62000个字符。字段中有（MEMO）标识。在表格界面输入时，首先单击要输入备注字段（MEMO）,再右侧空白对话框，出现闪烁光标，可以进行任意的文本输入。输入完毕，单击下一字段，输入的内容将自动保存。当是（Memo）时，表示尚未有备注，当是（MEMO）时表示已经加入了备注。
        （5）“日期”类型：用来输入日期或时间值。其长度为系统默认长度，为8个字节。本系统有万年历的功能。
        （6）“逻辑”类型：其长度为系统默认长度。
        （7）“二进制”类型：可以用来存放图形。
(8）“自动编号”类型：其作用是在添加记录时自动插入的序号每次加1。
（9）“货币”类型：用来定义货币数据，最长长度为8个字节。


信息表编辑器

    利用信息表编辑器来创建、设计和维护信息表。

    【打开信息表编辑器】

    通过菜单：“工具－信息表编辑器”可以打开信息表编辑器：

    【创建信息表】

        单击“新建”按钮，可以创建信息表，在弹出的信息框里输入信息表的名称，系统进入信息表设计界面：

    根据信息表结构的要求，分布指定序号、字段名称、类型和长度。这里序号表示字段在表中所处的位置，可以通过调整序号来改变字段排列顺序，序号可以为小数。

    点击确定按钮可以完成和保存当前信息表设计工作。系统出现重新回到信息表列表窗口。

    【信息表的删除】

  选中所要删除的信息表，单击删除按钮，系统提示“真的删除选定的信息表么？”，如果选择“是”按钮，就会删除选定的信息表。

    【信息表改名】

选中你要改名的信息表，然后单击"改名"按钮，然后输入新的名称，确定即可完成改名操作。

    【信息表复制】

    选中所要另存为的信息表单击鼠标右键，在弹出菜单中，选择“另存为”，在弹出的信息框中输入一个新的名称，确定即完成复制。


信息节点关联信息表

    信息表只有和信息树的信息节点关联起来，才能录入、显示、查询、报表输出和分析等。创建了信息管理树后，可以方便的将信息节点和信息表关联起来。

    在选定的信息节点上单击鼠标右键，弹出快捷菜单，通过菜单“信息关联设置-设置信息表(源)”即可打开设定/改变信息表(源)窗口：

    在“使用数据表”右边的下拉列表中选择关联的表即可。


表格界面概述

    主窗口的信息显示区就是表格界面显示的全部区域。

    表格界面是信息展现的基本方式，系统为表格界面提供了丰富的功能设置。

    标题，当前记录，记录数，记录导航

    记录筛选设置

    字段筛选设置

    表格界面设置

    表格辅助录入设置

    表格界面预览打印

    临时筛选

    复合筛选


记录筛选设置窗口

    记录筛选设置窗口用来对当前信息节点关联的数据源（主表）的记录进行筛选设置，而且可以将设置的筛选信息进行保存，以备下次使用。筛选信息被保存供下次使用是记录筛选设置窗口和复合筛选窗口的主要区别。

    【记录筛选设置窗口】

    通过单击主窗口工具栏上的“记录筛选设置”按钮 [image],可以进入记录筛选设置窗口。

    窗口上方的四个下拉列表分别是：字段列表、运算符列表、条件值列表和后续选项列表。

    字段下拉列表：自动包含当前数据源(主表)的所有的字段名称列表；

    运算符列表：可以选择“=”“>”“>=”“<”“<=”“Like”等项目；

    条件值列表：可以输入条件值或者选择系统提供的条件值；

    后续选项列表：确定是否还有后续条件设置。

    筛选列表框：用来存放已经设置和保存的筛选项目。

    筛选条件文本框：显示当前筛选的详细条件设置。

    在窗口右侧有一系列按钮，用来完成对筛选的系列功能。

    增加筛选：单击该按钮可以增加新的筛选，新的筛选需要输入筛选名称，以便保存和调用。

    添加到筛选条件：在一步的筛选条件设置完成后，通过点击该按钮将生成的条件追加到条件文本框。

    测试筛选：筛选设置完毕后，需要通过该单击按钮来进行测试，只有测试通过后才能保存和以后调用。

    调入表格筛选：如果表格界面数据源（主表）已经执行了某个筛选，通过该功能可以将筛选条件导入到条件文本框。

    保存筛选：保存通过测试的筛选，如果筛选没有测试，该按钮为灰色（不可用）。

    删除筛选：删除筛选列表中当前选定的筛选。

    【记录筛选设置调用】

    记录筛选设置保存后，可以在以后方便的调用。在表格底部的工具栏中：

    第一个下拉列表可以调用当前节点的记录筛选设置信息。如果当前节点已经设置了记录筛选信息，在当前节点打开时，第一个记录筛选设置会被自动应用，如上面的筛选设置“计算机二班”。可以通过选择不同的记录筛选设置名称来实施不同的筛选。


字段筛选设置窗口

    字段筛选设置窗口用来对当前信息节点关联的数据源（主表）的字段显示进行设置，而且可以将设置的筛选信息进行保存，以备下次使用。

    【字段筛选设置窗口】

    通过单击主窗口工具栏上的“字段筛选设置”按钮 [image],可以进入字段筛选设置窗口。

    字段筛选类型：用来存放已经设置和保存自动包含当前数据源(主表)的所有的筛选类型列表；

    增加筛选按钮：增加新的筛选类型；

    保存筛选按钮：保存设置的当前筛选；

    删除筛选按钮：删除字段筛选类型列表中选定的筛选类型；

    执行筛选按钮：执行当前选定的筛选类型；

    显示字段：希望在表格界面（主表）显示的字段列表；

    待选字段：当前表格界面中可以显示的字段列表

    增加按钮：通过单击增加按钮，可以将待选字段列表中选定的当前字段增加到显示字段列表中。

    移去按钮：通过单击移去按钮，可以将显示字段列表中选定的当前字段转移到待选字段列表中。

    【字段筛选设置调用】

    记录筛选设置保存后，可以在以后方便的调用。在表格底部的工具栏中：

    第二个下拉列表可以调用当前节点的字段筛选设置信息。如果当前节点已经设置了字段筛选信息，在当前节点打开时，第一个字段筛选设置会被自动应用，如上面的筛选设置“精简内耳”。可以通过选择不同的字段筛选设置名称来实施不同的字段显示方式。


表格界面设置窗口

    通过表格界面设置窗口，可以对表格界面的表格（主表和从表）的显示界面进行各种控制，以便使表格界面以自己希望的风格显示。

    【进入表格界面设置窗口】

    用鼠标点击主窗口工具栏“表格界面设置”按钮 [image] ，即可进入表格界面设置窗口。

    窗口的最上方表格下拉列表用来指定当前进行设置的表格是哪个信息表，可以是主表或者某个从表。

    表格界面设置窗口分为两页：表格属性、列属性。

    【表格属性】

    表格属性页主要对表格的总体属性进行设置。

    表格边框显示：确定表格是否显示边框。

    信息内容只读：确定表格数据是否设置为只读或可读可写。

    表格颜色：设置表格显示的颜色。

    固定项颜色：设置表格的固定项（表格标题、表格左侧等）固定不变的部分的显示颜色。

    表格字体属性：设置表格主体区字体属性。

    表格标题字体属性：设置表格标题字体属性。

    显示列线：设置表格是否显示列线。

    显示行线：设置表格是否显示行线。

    表格显示可见：设置表是否隐藏。

    删除时确认：确定记录被删除时是否进行确认，该设置对录入窗口同样有效。

    【列属性页】

    列属性页设置表格界面中和列相关的属性。

    当前设定列(字段)：指定需要进行设置的列的字段名称，下面的列属性的设置均是很对这里指定的字段名称。

    列颜色：指定当前列的颜色。

    列内容只读：设置当前列是否只读或可读可写。

    列宽度：设置当前列的列宽。

    列标题：设置当前列的列标题，可以根据需要设置为与字段名称不同的内容做为标题。

    标题颜色：设置标题的颜色。

    编辑格式：

    显示格式：

    当前列字体属性：设置当前列的字体属性。

    当前列标题字体属性：设置当前列标题字体属性。

    可用选择内容：设置用户在用该表格录入时，当前列是否出现下拉列表提供用户选择输入的内容，以及需要选择的列表项的内容。

    取消当前列属性设置：如果系统将对当前列的各种属性设置取消，恢复到缺省状态，使用该属性按钮。


字段编辑格式控制

    很多情况下需要指定编辑字段文本的输入格式，可以在表格界面设置窗口的列属性页中对“编辑格式”进行设置来达到目的。本节对各种可用的格式进行详尽说明。

    指定编辑字段的输入格式，运用该属性限制字符的输入，它指定了哪些字符是有效的，允许输入，哪些是无效的，步允许输入。

    输入格式有三段组成，以分号将段隔开，第一段为输入要求，指示哪些输入是有效的；第二段为一个字符，确定是否格式中的文字字符也做为数据的一部分存储；第三段也是一个字符，它代表格式字符串中未输入的字符。

    在第一段中，一些特殊的字符用户格式字符串，其意义如下表所示：

字符 | 在格式字符串中的意义
! | 如果“!”存在，任意字符出现在字段输入的前面空格中，如果“!”不存在，任意字符出现在字段输入的后面空格中。
> | 使“>”符号之后的字母变为大写字母，直到结束或遇到“<”符号为止。
< | 使“<”符号之后的字母变为小写字母，直到结束或遇到“>”符号为止。
<> | 如果“<>”这两个符号一起出现，不检查大小写。
\ | 跟在该符号之后的字符，可以是格式字符的特殊字符。
L | 在该位置要求一个字母字符，如：A-Z,a-z。
l | 允许一个字母字符在该位置，但不一定需要它。
A | 要求一个字母或数字字符在该位置，如：A-Z,a-z，0-9。
a | 允许一个字母或数字字符在该位置，但不一定需要它。如：A-Z,a-z，0-9。
C | 要求一个任意的字符在该位置
c | 允许一个任意的字符在该位置，但不一定需要它。
0 | 要求一个数字字符在该位置
9 | 允许一个数字字符在该位置，但不一定需要它。
# | 允许一个数字字符或“+”，“-”号在该位置，但不一定需要它。
: | 该符号用于分隔时、分、秒
/ | 用于分隔年、月、日
; | 分隔格式字符串中的三段
_ | 自动在文本中插入空格

    没有出现在上面表中的字符可以做为文字出现在格式字符串中的第一段中，文字字符必须与编辑控制相匹配，它们自动插入，在编辑过程中，光标会跳过这些字符。在反斜线（/）后的特殊字符也做为一般的文字出现在编辑框中。

    格式字符串的第二段是一个字符，它表示是否屏蔽格式字符串中的文字做为编辑的一部分，例如：包括区号的电话号码有下面的形式：

    (000)_000-0000;0;*

    它表示实际的编辑框中的值是10个数字，而不是14个数字。

    第三段也是一个字符，它代表格式字符串中未输入的字符。


字段显示格式控制

    【日期字段】

格式 | 显示
c | 短日期格式(2005-1-1)
d | 月份的第几天，没有前导0(1-31)
dd | 月份的第几天，有前导0(01-31)
ddd | 星期几
dddd | (同ddd)
ddddd | 短日期格式(2005-1-1)
dddddd | 长日期格式(2005年1月1日)
m | 月份，没有前导0
mm | 月份，有前导0
mmm | 月份，中文
mmmm | (同mmm)
yy | 短日期年份(01)
yyyy | 长日期年份(2001)
h | 无前导0小时
hh | 有前导0小时
n | 无前导0分钟
nn | 有前导0分钟
s | 无前导0秒钟
ss | 有前导0秒钟
t | 短时间格式（无秒）
tt | 长时间格式（有秒）

    【数字字段】

格式 | 显示
0 | 0占位符
# | 小数点前根据实际数值显示，小数点后0占位
, | 分段符显示
E+ E- | 科学记数法


表格界面辅助录入设置

    表格界面辅助录入用来设置当前表格界面（主表）的辅助录入功能。目标是提高用户录入数据的效率和准确性。

    用鼠标点击主窗口工具栏“表格辅助录入设置”按钮 [image] ，即可进入表格界面辅助录入设置窗口。该窗口分为两部分选择性辅助录入和表格辅助录入。

    【选择性辅助录入】

    采用这种方式，在表格界面进入设置好的字段时，字段将出现下拉列表框，用户可以从下拉列表框中选择设定的内容。

    辅助字段：指定进行辅助选择输入的字段名称。

    可选值：在下拉列表中可供选择的值，每行存放一个可选项目。

    【表格辅助录入】

    辅助字段：指定针对表格控件的哪个字段项目进行辅助录入。

    参考信息源：指定参考的数据记录来源，有两种情况：采用信息表和使用SQL语句。在使用SQL语句时，使用其右边的倒实心三角形按钮实施应用。

    推测字段：指定参考数据源里用来和辅助字段相比较的字段名称。

    附带字段：在参考数据源显示匹配记录时，显示的字段名称列表。

    字段替换关系：设置参考数据源记录的字段对表格控件的字段的一一对应替换关系。注意辅助字段和推测字段不要在这里设置为替换关系。

    保存当前辅助：如果上面设置完毕，通单击该按钮可以将辅助设置保存起来。

    撤销当前辅助：撤销当前的辅助录入设置。


记录分组查询窗口

    通过记录分组查询窗口，可以对表格界面的记录（主表）的显示记录进行快速筛选，记录分组的组别（节点）是根据表格界面的记录设定字段列表的内容自动生成的。

    【进入记录分组查询窗口】

    执行菜单：信息－信息关联设置－记录分组查询设置，可以打开记录分组查询窗口，设置是针对当前信息节点的。下图是针对一个国内的邮编区号信息表的筛选设置，实现了根据“省份－区号－城市”三个字段生成查询组别。

    设置分组可以采用两种方式：字段方式和SQL语句方式。

    字段方式：从“待选字段列表”中双击或通过选择分组字段并单击“增加”按钮，可以指定分组字段，分组字段的个数没有限制。然后单击“执行”按钮即可生成查询组别内容。如果单击“保存”按钮，该分组信息设置将被保存，在下次进入节点时自动启动分组查询窗口。

    SQL方式：从“SQL方式”页中设置SQL语句，如下图，然后单击“执行”按钮即可生成查询组别内容。如果单击“保存”按钮，该分组信息设置将被保存，在下次进入节点时自动启动分组查询窗口。

    如果节点设置了分组信息，在系统进入该节点时，系统将自动打开对应的分组窗口，打开的分组窗口自动隐藏了设置界面，如下图，通过点击对应的组别，系统将自动对表格界面（主表）记录进行自动筛选。


创建和修改录入窗口

    【新建录入窗口】

    录入窗口做为信息单元的一个部分，是和节点对应的，节点只有在和数据源（信息表或查询）关联后，对其设计录入窗口才有意义。

    在需要设计录入窗口的节点上单击鼠标右键，在弹出的快捷菜单中选中录入窗口―新建录入窗口，系统弹出信息框要求为录入窗口确定一个名称，根据需要起一个有意义的名字即可，系统弹出录入窗口设计界面。

    【录入窗口设计界面功能说明】

    窗口分为三部分：工具栏、工作区和属性条。

    工具栏：最上面的部分是工具栏，包括控件按钮和功能按钮。

        关于工具栏控件按钮

控件 按钮 | 名 称 | 功 能 | 主要属性
 | 标签 | 通常用于在界面中显示固定信息，如界面标题及某些对象的功能等 | 标题
 | 形状 | 形状控件用于在界面上制作矩形、正方形、圆角矩形、圆角正方形、椭圆形、圆形。同一种控件制作哪一种图形，这取决于对其“形状”属性的设置。 | 形状
 | 数据标签 | 用于显示系统自动计算得出的数据值，或不需要修改的数值。 | 绑定数据源 绑定字段
 | 编辑框 | 编辑框是录入窗口界面上的主要输入对象，但有时也用于输出。用于输入对象时，既可以输入文字，也可以输入数字字符，用作何种用途，由绑定字段决定。 | 绑定数据源 绑定字段
 | 备注文本 | 当要录入的文本较大时通常选用备注文本作为录入对象 | 绑定数据源 绑定字段
 | Rich文本 | 除了具有备注文本的功能外，还支持丰富文本格式 | 绑定数据源 绑定字段
 | 检查框 | 检查框用于输入逻辑或文本型字段，被选中的复选框在其复选框中打上“√”标记或其它标记。 | 绑定数据源 绑定字段 选定字符串 未选定字符串
 | 列表框 | 主要用来选择一组预定的数据，当选项内容在列表区域不下时，可通过滚动条游览列表的其他选项。 | 绑定数据源 绑定字段 列表框选项
 | 查找列表框 | 类似列表框，但是起选项内容来自于从表的字段 | 绑定数据源 绑定字段 参考数据源 参考字段 取值字段
 | 表格 | 以表格的形式在录入窗口显示数据 | 绑定数据源
 | 图形 | 绑定图形字段(二进制类型)，从而可以管理照片等图形信息。 | 绑定数据源 绑定字段
 | 固定图形 | 用户在录入窗口放置固定的图形 |
 | OLE控件 | Ole文档是把一个对象以链接或嵌入的方式包含在应用程序中。可以通过该控件在自己的应用程序中使用其他的应用程序，如Excel、Word等。 | 绑定数据源 绑定字段
 | 数据导航 | 用于定位记录。 | 绑定数据源

        关于工具栏功能按钮

控件 按钮 | 功 能
 | 重新读入保存的录入窗口设计信息，当前的设计和修改作废。
 | 保存当前的录入窗口设计信息
 | 清除当前设计的录入窗口版面信息
 | 录入窗口面板设置信息，可以设置录入窗口大小、导入字段等多种功能，可以大大提高录入窗口设计的效率和质量。
 | 复制当前选定控件，生成一个新的控件。
 | 删除当前选定控件
 | 针对当前录入控件设置辅助录入功能，使用辅助录入可以大大提高用户录入数据的效率。
 | 根据当前设计的录入窗口格式显示录入窗口，便于确定设计的效果，从而改进设计。
 | 根据当前设计的录入窗口格式生成一张报表。
 | 当前选定控件前移
 | 当前选定控件后移
 | 显示/隐藏属性列表

    工作区：录入窗口设计区。

    属性表：显示当前选定控件的各种属性，可以在这里修改相应的属性。

属性名称 | 说明 | 适用控件
标题 | 控件显示的文字内容 | 标签，检查框
左边距 | 控件距离左边的像素数值 | 所有控件
上边距 | 控件距离上边的像素数值 | 所有控件
宽度 | 控件的宽度数值，用像素做为度量单位 | 所有控件
高度 | 控件的高度数值，用像素做为度量单位 | 所有控件
文字排列 | 确定控件在文字排列对齐方式 | 标签，数据文本，备注文本，Rich文本
自动大小 | 如果文字过多，控件宽度是否自动增大 | 标签，数据文本，图形
字体 | 控件字体设置 | 标签，数据文本，编辑框，备注文本Rich文本，检查框，表格，列表框，查找列表框
透明 | 确定控件是否透明显示 | 标签，数据文本
文字绕排 | 确定控件在文字过多时是否换行排列 | 标签，备注文本，数据文本，Rich文本
绑定数据源 | 需要关联绑定其数据字段的信息表或查询 | 数据文本，编辑框，备注文本，Rich文本，检查框，表格，列表框，查找列表框，图形，数据导航,OLE文本
绑定字段 | 需要绑定的字段名称 | 数据文本，编辑框，备注文本，Rich文本，检查框，列表框，查找列表框，图形，数据导航,OLE文本
刷子颜色 |  | 形状
刷子风格 |  | 形状
画笔颜色 |  | 形状
画笔方式 |  | 形状
画笔风格 |  | 形状
画笔线条宽度 |  | 形状
形状 |  | 形状
Tab顺序 | Tab键和回车键时焦点移动的顺序。 | 编辑框，备注文本，Rich文本，检查框，列表框，查找列表框，图形，数据导航,OLE文本，表格
框架 | 确定控件是否有边框 | 编辑框，备注文本，Rich文本，检查框，列表框，查找列表框，图形，数据导航,OLE文本，表格
滚动条 | 是否显示滚动条及其显示方式 | 备注文本，Rich文本
最大长度 | 最多录入的字符数 | 备注文本
选定字符串 | 检查框被选定时的字符串值 | 检查框
未选定字符串 | 检查框未选定时的字符串值 | 检查框
列表框选项 | 待选项目，可以用SQL语句替换 | 列表框
列表框风格 | 列表框显示风格 | 列表框
背景颜色 | 控件的背景颜色 | 标签，数据文本，编辑框，备注文本，RICH文本，检查框，列表框，查找列表框，图形
在位激活 | OLE是否在位激活 | OLE文档
尺寸方式 |  | OLE文档
激活方式 |  | OLE文档
参考数据源 |  | 查找列表框
参考字段 |  | 查找列表框
取值字段 |  | 查找列表框
按钮设置 | 数据导航控件的按钮种类设置 | 数据导航
数据只读 |  | 所有可编辑控件
表格设置 | 打开表格设置对话框，对表格进行详尽设置。 | 表格
口令字符 | 以指定字符显示隐藏真是内容 | 编辑框
关联焦点控件 | 指定快捷键焦点移动的控件名称 | 标签


控件的基本操作

控件的基本操作

请选择所需主题：

    插入控件

    控件的选定和移动

    调整控件的大小

    删除控件

    使控件总在最前面

· 【插入控件】

    1、单击工具栏上所需插入的控件按钮。

    2、在工作区单击希望放置控件的左上角的位置。（如果单击并释放鼠标按钮，将创建默认大小的控件。如果是创建报表的控件，请单击所需插入的控件按钮，在报表下方的空白处单击，然后把控件移动到所需插入的位置）。

页首

· 【控件的选定和移动】

    1、选定控件（在控件中的任何位置单击(“Rich文本”控件应单击边框)）。

   也可单击设计窗口右侧属性表最上方的下拉列表框后面的下拉按钮，来选定控件。

    2、把指针移动到控件上，按下鼠标按钮不释放并拖动，即可把所选控件移动到所需位置（“Rich文本”控件应将鼠标移向控件的边框然后拖动）。

注意

    · 如果单击了某个已经选定的控件，则在控件中会显示一个插入点，以便输入或编辑文本，如果要选择控件，请单击控件以外的区域，然后再重新单击该控件的边框。

页首

· 【调整控件的大小】

    1、单击选定要调整大小的控件。

    2、拖动控件中调整大小的控点，直到控件变为所需的大小。

注意

    · 在属性栏上的“宽度”属性框中单击，然后在该框中键入新的宽度可调整控件的宽度。

    · 在属性栏上的“高度”属性框中单击，然后在该框中键入新的高度可调整控件的高度。

页首

· 【删除控件】

    1、单击所需删除的控件。

    2、单击工具栏上的“删除控件”按钮 [image] 。

页首

· 【使控件总在最前面或者最后面】

    1、选中希望操作的控件。

    2、单击工具栏上的“前面”或者“后面”按钮

页首


录入面板设置窗口

    在录入窗口设计界面，单击“版面设置”按钮 [image] ，可以打开录入面板设置窗口：

    通过该窗口可以对设计的录入窗口进行各种详尽的设置，而且通过导入功能提高设计效率。

    【多记录编辑方式】和【多记录设置】

    该类选项是为了兼容前期版本的功能，不推荐使用该功能，可以通过使用表格控件实现类似功能，并且在功能支持上更完美。

    【使用多页控制】和【多页设置】

    很多情况下录入窗口需要显示很多的信息条目，但是录入窗口的大小是有限的，这种情况下可以使用多页控制，把信息条目分类放置的多页控制的多个页面上。

    使“使用多页控制”处于选定状态，即可启用多页控制。

    多页设置：可以通过设置上边距、右边距、宽度和高度可以设置多页控制在录入窗口的位置和大小。通过设置风格可以确定多页控制标题的显示方式，通过设置Tab位置属性，可以确定多页控制标题的位置放置方式。最初的多页控制使没有页面的，可以通过“增加”按钮增加页面使用“删除”按钮删除选定页面，使用“改名”按钮可以未页面更好标题，以便于最终用户识别。

    【录入面板属性】

    录入窗口的主要区域就是录入面板，通过设置录入面板的大小和界面显示方式就可以决定设计的录入窗口的大小和显示风格。

    自动大小：如果选定该项，系统会根据录入面板内分布的控件的情况自动确定面板大小。后面的高度和宽度属性就不再起作用。如果希望二者起作用，需要将自动大小属性处于未选定状态。

    面板基本显示属性：通过设置内斜面、外斜面、斜面宽度、边框、边框宽度、面板颜色、字体等属性，可以改变面板的显示风格，并且可能对其内部控件产生影响，例如：使用默认字体的控件会根据面板字体的变化而同时改变。

    背景：如果希望录入窗口有一个好看的背景，可以通过“背景”按钮来为面板（录入窗口）平铺一个图像。

    网页：录入窗口支持将网页，通过“网页”按钮，可以在录入窗口内显示网页。在输入网页地址时，可以使用外部网址和本地网页，如果是本地网页，考虑的系统的移植性，建议使用相对路径，即使用.\和..\表示信息管理系统当前路径和上一级路径。例如：假设信息管理系统的路径下有网页文件：background.htm,在路径可以描述为：　.\bacground.htm.

    系统支持对网页连接的分析，可以通过网页设置对平台内部功能和信息管理系统其它功能的调用，具体请参见网页连接支持。

    【自动导入表格字段】

    该部分功能用来快速在录入面板上根据指定的数据源和指定的字段列表导入项目，通过导入可以快速建立项目，而且自动产生字段对应的标签、编辑框。然后简单的通过位置调整就完整了录入窗口的设计，效率很高。

    数据源：很多情况下，当前信息节点包括多个数据源，比如主从表，这时可以通过数据源选项选择需要在录入窗口导入字段的数据源名称。

    待选字段列表：很多情况下，并不是指定数据源的所有字段项目都要出现在录入窗口上，因此可以在待选字段列表上只选定导入后需要出现在录入面板上出现的字段。导入是只有选定的字段才会被导入到面板的指定位置。

    导入选项设置：用来设置导入字段时的某些选择。“包含字段名标签”确定是否在导入时自动创建以对应字段名为标签的项目说明；“控制带边框”确定导入的编辑框是否有边框，开发者可以根据录入窗口的风格选定；“控制表格环绕”确定是否在编辑框等控件的周围创建一个图形控件，这个只有在特殊情况下选中，一般情况下不需要选中；“表格顺序”确定是否按照表格界面字段的显示顺序和名称来分布在录入面板上，一般情况下该项选中，开发者可以通过在表格界面通过鼠标来改变对应字段的列宽度来实现在导入时自动修正导入的字段宽度。

    导入位置设置：导入位置有两种：主面板和多页控制的页面；上距、左距、列距、行距确定导入的位置分布，上距和左距是指最初导入的开始位置；列距和行距是指导入的字段形成的项目的行列间距，均以像素做为衡量单位。

    指定列数：如果该项选定，系统会自动以该项规则将导入项目按照指定的列数分布。

    以上选项设置完毕，通过单击“开始导入”按钮，即可完成导入功能，在录入面板指定位置按照指定的方式将指定的字段导入。

    【界面控件风格设置】

    该部分统一设置录入窗口的标签、编辑框、备注文本、Rich文本、列表框、查找列表框等控件的显示风格。

    斜面存在：设置控件的四个斜面是否显示。

    内斜面样式、外斜面样式：确定内、外斜面的显示样式。

    斜面风格：确定斜面的显示风格。

    斜面宽度：斜面的宽度，单位为像素。

    边框风格：确定是否显示边框。

    透明（标签控件）：确定标签控件是否透明显示，在设置窗口背景时，应该选择标签的透明属性。

    应用选定控件按钮：对设计窗口中当前选定的控件应用上面的属性设置。

    应用全控件按钮：对设计窗口中全部的控件应用上面的属性设置。


录入窗口表格控件设置

    【进入表格控件设置窗口】

    如果在录入窗口设计界面已经创建了表格控件，用鼠标点选该控件，然后单击右侧属性表中的“表格设置”属性按钮，即可进入表格控件设置窗口。

    表格控件设置窗口分为三页：表格属性、列属性、辅助录入。

    【表格属性】

    表格属性页主要对表格控件的总体属性进行设置。

    表格边框显示：确定表格是否显示边框。

    信息内容只读：确定表格数据是否设置为只读或可读可写。

    表格颜色：设置表格显示的颜色。

    固定项颜色：设置表格的固定项（表格标题、表格左侧等）固定不变的部分的显示颜色。

    表格字体属性：设置表格主体区字体属性。

    表格标题字体属性：设置表格标题字体属性。

    显示列线：设置表格是否显示列线。

    显示行线：设置表格是否显示行线。

    表格显示可见：设置表是否隐藏。

    显示水平滚动条：设置表格控件底部是否显示滚动条，如果不选定，则底部显示汇总条，针对每个数字列显示汇总数值。

    显示字段：设置表格控件显示指定数据源的哪些字段。

    【列属性页】

    列属性页设置表格控件中和列相关的属性。

    当前设定列(字段)：指定需要进行设置的列的字段名称，下面的列属性的设置均是很对这里指定的字段名称。

    列颜色：指定当前列的颜色。

    列内容只读：设置当前列是否只读或可读可写。

    列宽度：设置当前列的列宽。

    列标题：设置当前列的列标题，可以根据需要设置为与字段名称不同的内容做为标题。

    标题颜色：设置标题的颜色。

    当前列字体属性：设置当前列的字体属性。

    当前列标题字体属性：设置当前列标题字体属性。

    可用选择内容：设置用户在用该表格录入时，当前列是否出现下来列表提供用户选择输入的内容，以及需要选择的列表项的内容。

    取消当前列属性设置：如果系统将对当前列的各种属性设置取消，恢复到缺省状态，使用该属性按钮。

    【辅助录入页】

    辅助录入页用来设置当前表格控件的辅助录入功能。目标是提高用户录入数据的效率和准确性。

    辅助字段：指定针对表格控件的哪个字段项目进行辅助录入。

    参考信息源：指定参考的数据记录来源，有两种情况：采用信息表和使用SQL语句。在使用SQL语句时，使用其右边的倒实心三角形按钮实施应用。

    推测字段：指定参考数据源里用来和辅助字段相比较的字段名称。

    附带字段：在参考数据源显示匹配记录时，显示的字段名称列表。

    字段替换关系：设置参考数据源记录的字段对表格控件的字段的一一对应替换关系。注意辅助字段和推测字段不要在这里设置为替换关系。

    保存当前辅助：如果上面设置完毕，通单击该按钮可以将辅助设置保存起来。

    撤销当前辅助：撤销当前的辅助录入设置。


录入窗口辅助录入设置

    为了提高用户输入数据的效率和准确性，很多情况下可以对编辑框和列表框进行辅助录入。

    所谓辅助录入，就是用户在输入某个字段的值时，如果系统中已经存在类似的内容，系统自动将上次录入的类似内容进行填充。

    【进入辅助录入设置窗口】

    在录入窗口设计界面，鼠标单击需要进行辅助录入的字段，然后单击工具栏上的“辅助录入设置”按钮 [image] ，系统进入辅助录入设置窗口：

    【窗口组成】

    数据源：是指辅助录入编辑框（列表框）在用户录入时系统需要自动参考和显示的数据来源，有信息表和SQL语句两种情况，根据需要选择其中的一种即可。

    推测字段：指定参考数据源里用来和辅助字段相比较的字段名称。

    附带字段：在参考数据源显示匹配记录时，显示的字段名称列表。

    字段替换关系：设置参考数据源记录的字段对表格控件的字段的一一对应替换关系。注意辅助字段和推测字段不要在这里设置为替换关系。

    确定按钮：如果上面设置完毕，通单击该按钮可以将辅助设置保存起来。

    撤销当前：撤销当前的辅助录入设置。

    支持计算公式：如果没有设置辅助录入，但是选定了该项功能，则系统支持“=”号公式计算，例如：如果在编辑框中输入了“=4+5”，则在焦点离开该编辑框时，编辑内容自动变为“9”。该功能仅对文本类型的字段对应的编辑框有效。


创建和修改报表

    【新建报表】

    报表做为信息单元的一个部分，是和节点对应的，节点只有在和数据源（信息表或查询）关联后，对其设计报表才有意义。

    在需要设计报表的节点上单击鼠标右键，在弹出的快捷菜单中选中报表输出―新建报表，系统弹出信息框要求为报表确定一个名称，根据需要起一个有意义的名字即可，系统弹出报表设计窗口。创建新的报表时，报表设计窗口的工作区是空白的。为了便于理解，这里打开的是已经包含设计内容的报表设计窗口。

    【报表设计窗口功能说明】

    窗口分为三部分：工具栏、工作区和属性条。

    工具栏：最上面的部分是工具栏，包括控件按钮和功能按钮。

        关于工具栏控件按钮

控件
按钮
名　称
功　　　　能
 主要属性
标签 | 通常用于在报表中显示固定信息，如界面标题及某些对象的功能说明等 | 标题
形状 | 形状控件用于在界面上制作矩形、正方形、圆角矩形、圆角正方形、椭圆形、圆形。同一种控件制作哪一种图形，这取决于对其“形状”属性的设置。 | 形状
表达式 | 用于设置针对字段的各种公式计算。 | 绑定数据源
数据文本 数据文本是报表的主要输出对象，输出的内容由绑定字段决定。 绑定数据源
绑定字段
联合Rich文本 | 使用{[]}标注字段名称，报表在输出时会自动将字段名称替换为对应字段的内容，一个控件中可以包括多个字段标注，并且和和一般的文字描述同时出现。该控件不能出现在表头区和细节区中。
字段Rich文本 除了具有备注文本的功能外，还支持丰富文本格式，和具体字段绑定 绑定数据源
绑定字段
计算框

可以构建段落方式的字段表达式，字段名次采用花括号{}标注，例如：

公司 : {CompanyName}
地址 : {Address1}
        {Address2}
联系 : {联系 + ' ' + Phone number}

 绑定数据源
系统数据 | 输出系统信息，包括：当前日期、当前时间、当前日期和时间、当前页的记录统计、当前记录号、报表页数、报表标题 | 信息类型
图形 绑定图形字段(二进制类型)，从而可以输出照片等图形信息。 绑定数据源
绑定字段
固定图形 | 用户在报表上放置固定的图形

        关于工具栏功能按钮

控件 按钮 | 功 能
 | 重新读入保存的报表设计信息，当前的设计和修改作废。
 | 保存当前的报表设计信息
 | 清除当前设计的报表版面信息
 | 录入设置信息，可以设置报表的分区、导入字段等多种功能，可以大大提高报表设计的效率和质量。
 | 复制当前选定控件，生成一个新的控件。
 | 删除当前选定控件
 | 根据当前设计的报表格式显示报表，便于确定设计的效果，从而改进设计。
 | 当前选定控件前移
 | 当前选定控件后移
 | 显示/隐藏属性列表

    工作区：报表设计区。

    属性表：显示当前选定控件的各种属性，可以在这里修改相应的属性。

属性名称 | 说明 | 适用控件
标题 | 控件显示的文字内容 | 标签，数据文本、表达式控件、计算框、系统数据控件
左边距 | 控件距离左边的像素数值 | 所有控件
上边距 | 控件距离上边的像素数值 | 所有控件
宽度 | 控件的宽度数值，用像素做为度量单位 | 所有控件
高度 | 控件的高度数值，用像素做为度量单位 | 所有控件
文字排列 | 确定控件在文字排列对齐方式 | 标签，数据文本，表达式控件，计算框，Rich文本，字段Rich文本文本，系统数据控件
自动大小 | 如果文字过多，控件宽度是否自动增大 | 标签，数据文本，图形
自动伸展 | 对于标签、数据文本等如果内容过多是否向下伸展 | 标签，数据文本、表达式控件、计算框、RICH文本
打印时可见 | 确定打印时是否可以显示和打印 | 所有控件
字体 | 控件字体设置 | 标签，数据文本，表达式控件，计算框，Rich文本，字段Rich文本文本，系统数据控件
框架颜色 | 控件的框架（边框）的颜色 | 标签，数据文本，表达式控件，计算框，Rich文本，字段Rich文本文本，系统数据控件
框架上边框 | 控件的框架（边框）是否显示上边框 | 标签，数据文本，表达式控件，计算框，Rich文本，字段Rich文本文本，系统数据控件
框架下边框 | 控件的框架（边框）是否显示下边框 | 标签，数据文本，表达式控件，计算框，Rich文本，字段Rich文本文本，系统数据控件
框架左边框 | 控件的框架（边框）是否显示左边框 | 标签，数据文本，表达式控件，计算框，Rich文本，字段Rich文本文本，系统数据控件
框架右边框 | 控件的框架（边框）是否显示右边框 | 标签，数据文本，表达式控件，计算框，Rich文本，字段Rich文本文本，系统数据控件
框架风格 | 控件的框架（边框）风格 | 标签，数据文本，表达式控件，计算框，Rich文本，字段Rich文本文本，系统数据控件
框架线宽度 | 控件的框架（边框）宽度 | 标签，数据文本，表达式控件，计算框，Rich文本，字段Rich文本文本，系统数据控件
透明 | 确定控件是否透明显示 | 标签，数据文本，表达式控件，计算框，系统数据控件
文字绕排 | 确定控件在文字过多时是否换行排列 | 标签，数据文本，表达式控件，计算框，系统数据控件
绑定数据源 | 需要关联绑定其数据字段的信息表或查询 | 数据文本，字段Rich文本文本
绑定字段 | 需要绑定的字段名称 | 数据文本，字段Rich文本文本
格式字符串 | 格式化数据输出格式 | 数据文本，表达式控件
表达式 | 打开表达式设置窗口 | 表达式控件，计算框，Rich文本
打印后重置 | 打印新的页前将数据清空 | 表达式控件
删除空行 | 删除其空白的行 | 计算框
刷子颜色 |  | 形状
刷子风格 |  | 形状
画笔颜色 |  | 形状
画笔方式 |  | 形状
画笔风格 |  | 形状
画笔线条宽度 |  | 形状
形状 |  | 形状
信息类型 | 系统信息的输出类型 | 系统数据控件
自动剪裁 | 如果图形不能完整显示，是否剪裁 | 图形控件，固定图形控件
图像居中 | 图像是否居中显示 | 图形控件，固定图形控件


报表版面设置窗口

 c
报表版面设置窗口

    在报表设计窗口，单击“报表设置”按钮 [image] ，可以打开报表版面设置窗口：

    通过该窗口可以对设计的报表进行各种详尽的设置，而且通过导入功能提高设计效率。

    【纸张大小】

    设置当前报表的纸张类型，如果选用自定义纸张（Custom），可以通过“宽”、“高”项目进行设置。纸张放置有竖放和横放两种方式。如果希望报表以多列的方式输出，可以设置“列数”项目，同时可以设置列宽数值。

    【边距】

    设置报表纸张的页边距的大小，包括：上边距、下边距、左边距和右边距。

    【边框】

    如果报表需要显示边框，可以分别对上边框、下边框、左边框和右边框分别进行设置，并可以设置边框的颜色和宽度。

    【背景图形】

    可以根据需要对报表的主体区（报表区）和各个其它带区分别设置背景图形，可以通过选择“自动大小”或“自动缩放”来选择图像的显示方式。

    【带区设置】

    可以通过使某个带区名称前面的检查框选定，以便在报表上增加对应带区，同时可以对当前的带区属性进行设置，包括带区高度、带区边框宽度、和带区边框的显示与否。

    同时还可以设定报表输出时是否首页打印页头和尾页打印页脚。

    【区间控件批量移动/复制操作】

    用来对整个带区的所有控件进行转移或复制操作，可以实现在带区内移动，带区间转移或复制功能。

    【报表缺省字体】

    如果希望改变报表的默认字体，请单击“报表缺省字体”按钮进行设置。

    【自动导入表格字段】

    该部分功能用来快速在报表上根据指定的数据源和指定的字段列表导入项目，通过导入可以快速建立项目，而且自动产生字段对应的标签、数据文本。然后简单的通过位置调整就完整了报表的设计，效率很高。

    数据源：很多情况下，当前信息节点包括多个数据源，比如主从表，这时可以通过数据源选项选择需要在报表导入字段的数据源名称。

    待选字段列表：很多情况下，并不是指定数据源的所有字段项目都要出现在报表上，因此可以在待选字段列表上只选定导入后需要出现在报表上出现的字段。导入时只有选定的字段才会被导入到报表的指定位置。

    导入选项设置：用来设置导入字段时的某些选择。“包含字段名标签”确定是否在导入时自动创建以对应字段名为标签的项目说明；“控制带边框”确定导入的数据文本是否有边框，开发者可以根据报表的风格选定；“控制表格环绕”确定是否在数据文本等控件的周围创建一个图形控件，这个只有在特殊情况下选中，一般情况下不需要选中；“表格顺序”确定是否按照表格界面字段的显示顺序和名称来分布在报表上，一般情况下该项选中，开发者可以通过在表格界面通过鼠标来改变对应字段的列宽度来实现在导入时自动修正导入的字段宽度。

    导入位置设置：导入位置有两种：单记录报表导入和多记录报表导入，前者一般所有内容在标题区中，后者一般要分布到表头区和细节区。上距、左距、列距、行距确定导入的位置分布，上距和左距是指最初导入的开始位置；列距和行距是指导入的字段形成的项目的行列间距，均以像素做为衡量单位。

    以上选项设置完毕，通过单击“开始导入”按钮，即可完成导入功能，在报表指定位置按照指定的方式将指定的字段导入。


报表公式设置

    针对报表设置，系统支持对三种控件进行公式设置：表达式控件、联合Rich文本控件和计算框控件。对三种控件的公式设置均通过如下操作实现：在报表设计窗口，用鼠标选中希望设置的控件（三种之一），然后单击右侧属性表中的“表达式”按钮启动表达式设置窗口。下面分别对三种控件的表达式设置给予说明

    【表达式控件的公式设置】

    表达式控件一般放置在报表的汇总区或者页脚区。可用函数如下：

函数名称 | 说明 | 备注
IF(<Exp>,<x>,<y>) | 条件函数，例如： IF([性别]='男','男性','女性') | 参数中可以引 用字段名称， 字段名称如果 为中文，请用 方括号([])括 起，字符串用 单引号。
STR(<x>) | 数字转换为字符串函数，例如： [姓名]+'的成绩是:'+STR([总分])
UPPER(<x>) | 小写转换为大写函数，例如： UPPER('abcd')
LOWER(<x>) | 大写写转换为小写函数，例如： LOWER('ABCD')
TIME | 时间函数
DATE | 日期函数
COPY(<x>,<St>,<Len>) | 求子字符串函数，如： COPY([姓名],1,2)
SUM(<x>) | 求和函数，例如： SUM([总分])
COUNT | 记录数统计
MAX(<x>) | 求某字段最大的值
MIN(<x>) | 求某字段最小的值
AVERAGE(<x>) | 求字段的平均值
True | 真值
False | 假值
INT(<x>) | 求整
SQRT(<x>) | 求二次方根
DIV(<x>,<y>) | 整除
TYPEOF(<Exp>) | 类型判定函数
FORMATNUMERIC(<f><<n>) | 输出格式化函数

【计算框控件的公式设置】

    该控件一般用于在大片的文本段落中插入字段内容时使用，字段参数用{}括起来，如果是中文字段，用{[]}括起来，具体用法可以参考上图。上图的输出应该类似下面：欢迎XXX：你的学号是:26

    【联合Rich文本控件的公式设置】

    联合Rich文本控件一般在单记录报表中使用，功能基本和计算框控件一样，而且支持通过点符号(.)对多个表的字段内容进行调用。


信息分析设计

    系统的信息分析窗口用来对当前信息节点所关联的数据源以各种分析图形的方式进行展示，方便用户参考和管理。

    在需要进行信息分析的信息节点单击鼠标右键，在弹出菜单中选择：信息分析－创建信息分析（新建）或打开信息分析（打开已经创建的），可以打开信息分析窗口。下图为已经创建好的一个信息分析示例。

    单击窗口上的“图形编辑”按钮 [image] ，可以进入图形编辑设置窗口：

    【增加新的分析数列】

    在上面的窗口中，点击“指定数列图形类型”的下拉框，选择希望创建的分析类型。选中“立体图形”检查框可以创建立体显示的分析图形，然后单击“增加数列图形”按钮，系统会要求输入一个名称做为分析数列的名称，输入确定后，系统就创建了一个指定类型的分析数列图形。

    此时分析图形是采用的内部示例数据，可以采用如下方法为数列图形分派指定的数值：单击创建的数列分析名称，使其处于选定状态，然后单击上面的“数列”页，然后选择“数据”页，出现如下界面：

    根据当前信息节点关联的数据源给数列赋值有两种取向方式，纵向选取赋值和横向选取赋值。如上图，设置完毕后，单击应用数据到图形，完成数列赋值操作。

    【对选定的数列进行各种修饰】

    设置数列图形的显示格式：

    设置数列图形的全局格式：

    设置数列图形的标志：

    对于折线图，还有“点”页设置：

  【对整个信息分析窗口进行各种修饰】

    全局：

    坐标系：

    标题：

    图例：

    面板：

    分页：

    墙面：

    立体：


记录计算与验证设置窗口

SQL方式计算与验证设置窗口

    SQL方式计算与验证用来对当前信息节点关联的数据源的字段间进行记录级别上的计算和验证。在记录的指定操作时触发。

    【SQL方式计算与验证设置窗口】

    通过执行主窗口当前信息节点上的右键弹出菜单：信息计算－SQL方式计算与验证设置,可以进入SQL方式计算与验证设置窗口。

    该设置分为两个部分，计算设定和验证设定。

    【记录计算设定】

    对指定字段进行计算替换设定。

    计算与验证设置列表：显示当前信息节点的全部SQL方式进行计算和验证的设置项目列表，可以用来选定和操作。

    名称：当前设置项目的名称。

    说明：当前设置项目的功能说明，便于以后理解和维护。

    类型：指定当前设置项目是计算类型还是验证类型。

    实施数据源：设定当前设置项目实施的数据源的名称。计算和验证均针对该数据源。

    触发数据源：触发该设置项目的数据源。

    触发执行点：触发数据源执行何种操作触发当前设置项目。

    执行SQL语句（组）文本框：存放当前设置项目需要执行的SQL语句（组）。

    执行SQL语句（组）按钮：执行存放在执“行SQL语句（组）文本框”中当前设置项目需要执行的SQL语句（组），并且将可以提供替换值的字段列表放置到“计算”的组合框中。

    计算：设置字段的替换关系。

    替换后自动保存：设置在字段替换后是否自动提交修改数据。

    【记录验证设置】

    记录验证设定用于设置在记录改变时，检查是否复合设定的验证标准。验证标准本身也时一个布尔表达式，如下图所示。

    验证提示方式：指定当复合何种标准时弹出提示框。

    提示内容：设定提示框显示时出现的提示内容。

    新建设置按钮：创建新的计算与验证设置项目。

    读取设置：重新读取当前已经保存的计算与验证设置项目的内容，当前修改的设置被取消。

    保存设置：保存当前的计算与验证设置项目的内容。

    删除设置：删除当前的计算与验证设置项目的内容。


记录计算与验证设置窗口

    记录计算与验证用来对当前信息节点关联的数据源（主表）的字段间进行记录级别上的计算和验证。在记录被添加和修改后保存时触发。

    【记录计算与验证设置窗口】

    通过单击主窗口工具栏上的“字段计算与验证”按钮 [image],可以进入记录计算与验证设置窗口。

    该窗口分为两个部分，记录计算设定和记录验证设定。

    【记录计算设定】

    对指定字段的计算公式进行设定。

    当前字段：指定进行计算公式设置的字段名称；

    计算公式：当前字段指定的字段的计算公式；计算公式除了支持常规的加减乘除运算外，还支持多种运算方式，列表如下：

四则运算 | 加减乘除及其优先级运算，支持利用括弧()改变优先级。
函数支持
函数类型 | 函数名称 | 说明 | 备注
数学函数 | tan()； |  |
 | sin()； |  |
 | cos()； |  |
 | sinh()； |  |
 | cosh()； |  |
 | arctan()； |  |
 | cotan()； |  |
 | arg()； |  |
 | exp()； |  |
 | ln()； |  |
 | log10()； |  |
 | log2()； |  |
 | square()； |  |
 | sqrt()； |  |
 | abs()； |  |
 | trunc()； |  |
 | ceil()； |  |
 | floor()； |  |
 | heaviside()； |  |
 | sign()； |  |
 | zero()； |  |
 | phase()； |  |
 | rnd()； |  |
 | random()； |  |
 | max()； |  |
 | min()； |  |
 | power()； |  |
 | IntPower() |  |
 | logN()； |  |
特殊函数 | $^ ； | 数字字段转货币大写 |
 | %^； | 数值字段转大写 |
 | #^DATE()； | 字段强制赋值当前日期 |
 | #^NULLDATE()； | 字段为空时，强制赋值当前日期 |
 | #^DATETIME()； | 字段强制赋值当前日期时间 |
 | #^NULLDATETIME()； | 字段为空时，强制赋值当前日期时间 |
 | @^PYM()； | 根据指定文本字段，将当前字段赋值拼音码。 |
 | @^CURUSER()； | 字段赋值当前用户名 |
 | @^NULLTRUE； | 如果字段为空，强制赋值TRUE |
 | @^NULLFALSE | 如果字段为空，强制赋值FALSE |
 | @^NULLFILL() | 如果字段为空，强制赋指定的信息值 |
字符赋值 | 直接输入的任何字符可以被直接赋值给指定字段

    待选字段：在公式设置中可以引用的字段名称，可以通过双击对应字段名称使其追加到计算公式文本框；

    待选操作：计算公式可以引用的计算方式；

    保存公式：保存设置的公式，公式只有测试正确后，才能调用该功能。

    删除公式：删除当"前字段"指定的字段名的公式计算设置；

    【记录验证设置】

    记录验证设定用于设置在记录改变时，检查是否复合设定的验证标准。验证标准本身也时一个布尔表达式，如下图所示，这里的验证基本限于数字计算相关的验证。

    窗口上面的四个下拉列表框分别为：字段选择列表框、运算符选择列表框、条件值录入选择列表框和后续续选择列表框，用来生成条件表达式。

    左边的列表框用来存放验证列表

    右边的文本框是用来存放验证条件的。

    增加验证按钮、保存验证和删除验证用来执行增加新的验证规则、保存设置或修改的验证规则和删除已经存在的指定的验证规则。


关联数据源时SQL语句信息处理

    在对信息节点进行“信息关联设置”时，我们可以使用查询，即SQL语句，系统在这里也支持SQL语句组，语句之间用GO间隔即可。

    通过这个功能，可以在语句组中执行各种需要的处理功能，然后在语句组的最后使用SELECT语句打开数据源即可。如下图：


触　发　器

    触发器用来在数据源（数据集，包括信息表和SQL语句等）被修改的前后和数据源打开前或关闭后即时触发执行系列SQL语句的。

    【进入触发器设置窗口】

    在信息管理树当前节点（选中节点）单击鼠标右键，在弹出菜单中选择：“信息计算－触发器设置”可以打开触发器设置窗口。

    【功能说明】

    数据源(集)：确定是对当前信息节点（选中节点）的主表或哪个从表设置触发器。

    过程触发状态：确定对指定数据源的哪个时间设置触发过程，包括：记录保存前、记录保存后、记录删除前、数据集打开前、数据集关闭后五个触发时间。

    触发字段：如果过程触发状态为“记录保存前”或“记录保存后”，则显示当前数据集的所有字段名称，可以选择在哪些字段被用户修改后才进行触发，而不是只要有记录被修改即触发。

    数据源(集)刷新：确定在触发被执行后，是否刷新数据集以体现触发执行的结果，如果某个数据源被选定，则系统会后台进行数据刷新，由于触发器执行结果被提交需要一定时间，所以刷新会在触发执行后的一个想当长的时间（例如4秒）里才执行，因此请慎用该功能。

    窗口的最下方是触发过程编辑框，用来存放存储过程。因为系统的设计是数据库无关的，因此系统仅支持由系列语句通过GO间隔排列的触发语句，不支持分支和循环，如果你需要更强的触发过程，建议使用数据库本身的触发器，例如SQL SERVER触发器。

    清空/删除当前过程按钮：该功能清除指定数据源指定触发方式的存储过程。


字段批量计算设置窗口

    字段批量计算设置窗口用来对当前信息节点关联的数据源（主表）的字段显示进行设置，而且可以将设置的筛选信息进行保存，以备下次使用。

    【字段批量计算设置窗口】

    通过单击主窗口工具栏上的“字段批量计算设置”按钮 [image],可以进入字段批量计算设置窗口。

    当前字段：指定进行计算公式设置的字段名称；

    计算公式：当前字段指定的字段的计算公式；

    待选字段：在公式设置中可以引用的字段名称，可以通过双击对应字段名称使其追加到计算公式文本框；

    待选操作：计算公式可以引用的计算方式；

    公式测试按钮按钮：测试公式设置是否正确；

    保存公式：保存设置的公式，公式只有测试正确后，才能调用该功能。；

    删除公式：删除当”前字段“指定的字段名的公式计算设置；

    计算处理：按照设置的公式进行计算。。

    【字段筛选设置调用】

    记录筛选设置保存后，可以在以后方便的调用。在表格底部的工具栏中：

    第三个下拉列表可以调用当前节点的字段批量计算设置信息。可以通过选择不同的列表项执行不同的字段计算，如果选择“所有计算字段”，系统会将所有字段计算公式均执行一次。


序列填充窗口

    序列填充窗口用来对当前信息节点关联的数据源（主表或从表）的记录的某个字段按照一定的规则进行自动数字填充。

    在当前信息节点上单击鼠标右键，执行弹出菜单：信息计算－序列填充，可以进入序列填充窗口。

    数据源：很多情况下当前信息节点可能同时管理主表和从表，通过该项可以选择希望序列填充的是主表或哪个从表。

    填充字段：在指定数据源中确定是对哪个字段进行填充。

    初始值：指定填充从哪个数值开始。

    步长值：两个最近的数值间的长度。

    终止值：填充到哪个数值时停止填充，一般为空，表示填充到最后的记录为止。

    固定位置前导零：如果选定该项，对于文本类型的字段填充编码类型时，系统自动保证以固定的位数填充，不足位数时，自动在数值前面填充0.

    位数：指定前导零时保持的固定位数长度。

    根据字段内容变化进行填充：如果选中该项，则填充会根据指定的字段进行比对，如果指定字段中有一个字段的内容发生变化，则填充数值递进。

    比对字段：用来指定比对的字段列表，可以有多个字段用来对比。

    待选字段：当前数据源用待选的字段列表。

    根据内容是否变化改变序列值：如果该项选定，则数值递增和记录移动无关，而是和比对字段比较,如果比对字段变化,那么比对字段再递增。

    开始填充按钮：根据设置的信息进行序列填充。


信息管理树概述

    【信息管理系统有多个信息单元构成】

    信息单元是指相对独立的信息集合的内容、运动流程和对外展现。在本系统中，通过信息表、录入窗口、表格界面、报表、处理、分析等方式实现对信息单元的管理和运用。

    【信息节点和具体的信息单元关联】

    信息管理树由不同层次和从属关系的信息节点构成，不同信息节点关联不同的信息单元。

    【利用信息管理树管理所有的信息单元】

    通过信息关联节点管理信息单元，实现了信息管理树对系统内各个信息单元的管理。

    【信息管理树体现信息管理系统】


信息管理树节点操作

    信息管理树的创建通过信息管理树的右键菜单完成：

    【信息节点和类节点】

    信息节点一般用来关联信息单元，类节点一般用来为信息节点分类或体现节点的从属关系。

    如果希望创建和当前节点（选中节点）同级别的节点，请使用“插入类节点”和“插入信息节点”。

    如果希望创建属于当前节点（选中节点）的子节点，请使用“插入子类节点”和“插入信息子节点”。

    如果没有选中节点或者信息管理树中没有节点，则自动创建第一个级别的节点。

    【节点改名】

    通过该功能可以更改当前节点（选中节点）的名称，以体现一定的意义。

    【删除节点】

    删除信息(类)节点：将当前节点（选中节点）包括其下级节点一起删除。

    删除子节点：将当前节点（选中节点）的下级节点删除，保留当前节点。

    删除节点并不删除节点对应的信息单元，如果确实需要同时删除信息单元，请预先通过其它删除操作删除。

    【功能说明】

    通过该功能可以对当前节点的功能意义进行文字说明，文字格式可以为Rich格式文本，其将在系统主窗口的下面显示出来。


信息节点和数据源

    【信息节点和数据源】

    数据源可以是信息表或查询，一个信息节点可以关联多个数据源，多个数据源之间可以有一个做为主表，其它的数据源做为主表的从表。如果信息节点只是关联一个数据源，一般通过在节点单击鼠标右键菜单，执行“信息关联设置－设定/改变信息表(源)”进行关联，对于其它的数据源关联，可以通过右键菜单的“信息关联设置－当前信息从表设置”进行关联。

    数据源可以是系统内部的信息表和查询，也可以是外部的信息表和查询，包括网络数据库，例如SQL SERVER的表和查询。

    信息节点只有关联数据源之后，针对该节点设计的录入窗口、报表、分析等才有意义。

    信息节点也可以关联非数据库类型的信息主要是WEB格式的信息。

    【设定/改变信息表(源)】

    在当前节点（选中节点）单击鼠标右键，在弹出菜单中执行“信息关联设置－设定/改变信息表(源)”，可以进入设定/改变信息表(源)窗口。

    连接数据库类型信息设置数据来源和数据访问选择。

    数据来源：可以选择系统内部和系统系统外部。

    系统内部指信息管理系统的内部，通过信息表编辑器创建的信息表或基于内部信息表的查询。

    系统外部指访问信息管理系统之外的其它各种常见的数据库格式的表或查询。如果访问系统外部数据，需要设置外部数据源的连接属性信息，通过单击“外部数据源”标签后面的"..."按钮可以进行设置。主要是选择对应数据库格式的驱动程序来对用户和密码的设置。

    数据访问选项共有如下选项：

    实表访问选项：如果选定，则信息的所有记录只被读入一小部分（几十条），后续的记录在需要时才被读入，因此在表格界面不能通过单击字段名标题来实现排序，一般用于记录内容经常相同和字段很多时采用；如果该选项不被选定，则信息的所有记录被一次性全部读入，支持表格界面单击字段标题排序功能，一般最好设置有ID自动编号字段，否则容易出现记录相同时无法定位的错误，如果包含过多的字段时也不易采用。因为记录标签的原因，某些数据库格式不支持实表访问选项被选定的情况。

    内容只读：确定信息内容是否只读。

    禁止删除：确定是否允许删除信息记录。

    禁止添加：确定是否允许添加信息记录。

    使用数据表：即信息表，如果直接连接信息表，可以通过其下拉列表选择存在的信息表名称。

    创建表按钮：可以通过该按钮调用信息表编辑器。

    使用查询语句：如果该项被选定，则使用查询语句，可以在下面的SQL编辑框中使用SQL语句做为查询。

    创建/编辑查询窗口：如果查询中有参数，可以设置查询窗口，如果不设置，系统会弹出缺省的参数窗口。

    删除查询窗口：清除当前信息节点设置的查询窗口。

    应用查询按钮：使设置的查询语句生效，如果单击确定按钮，也会使SQ语句生效。

    使用非数据库类型的信息：如果选择该项，当前信息节点将关联下面编辑框中输入的信息，一般为WEB格式，即网页或网址等。

    应用信息位置：尝试打开上面设置的非数据库类型信息。

    如果系统含有从表，可以在窗口下方输入主表的高度，以确定主从表各自显示的大小。

    【当前信息表从表设置】

    1、从表基本设置：

    基本设置包括上面窗口的上下两部分，上面的用来确定用哪个信息表或查询（SQL语句）做为当前信息节点（选中节点）的从表，下面对“从表列表”中选定的当前从表进行基本设置。

    从表选定：从表可以使内部信息表或查询，也可以是外部表和查询，如果选择内部表或查询，请让“数据来源”的“系统内部”选项处于选定状态，然后就可以从“信息表列表”列表框中选择信息表做为从表到“从表列表”中，使用按钮“->”“<-”进行操作。也可以在“信息表列表”下面的编辑框中输入SQL语句，然后单击“SQL->”按钮，同样可以将查询语句追加到从表列表中。

    从表基本设置：在从表列表中，用鼠标点选希望进行设置的从表，然后可以通过上面窗口的下半部分的多页控制的“基本设置”页，进行基本设置，主要是进行主从关系设置和确定从表标题、编辑、显示属性和导航设置。

    如果从表根据一定的规则和某个表有主从关系，可以通过“主从设定”来实现，基本原理是让主表和从表的字段有一对或多对对应关系，在主表记录移动时，从表根据主表的关联字段内容自动对从表进行筛选。具体操作为：通过选定主表“指定某个表做为主表，选定主表字段，选定从表对应关联字段，然后单击“增加”按钮，则对应关联字段被追加到“主从关系字段”列表，从而确定了主从表关联关系。根据需要，主从关联字段可以有多对。可以通过“删除关系”按钮来将“主从表关系字段”列表中选定的关联删除。

    从表的按钮标题可以通过“标题”对话框进行修改，以便于用户在表格界面操作时便于识别和操作。

    “数据只读”用来确定从表是否只读或者可读可写。

    “从表可见”确定从表是否在表格界面显示。很多情况下从表可能只在录入窗口、报表等地方显示和输出。

    “数据导航条”默认显示所有的导航按钮，可以通过改变其前面的检查框的值来确定显示哪些导航按钮。

    “级联处理”确定对于主表记录删除时，是否同时删除从表的级联记录。

    【从表显示字段】

    通过多页控制的“显示字段”页来进行设置，把需要显示的字段从“待选字段”中移动到“显示字段”列表中即可。

    【从表录入选择】

      采用这种方式，在表格界面进入设置好的字段时，字段将出现下拉列表框，用户可以从下拉列表框中选择设定的内容。

    操作字段：指定进行辅助选择输入的字段名称。

    可用选择内容：在下拉列表中可供选择的值，每行存放一个可选项目。

    【从表录入辅助】

    辅助字段：指定针对表格控件的哪个字段项目进行辅助录入。

    参考信息源：指定参考的数据记录来源，有两种情况：采用信息表和使用SQL语句。在使用SQL语句时，使用其右边的倒实心三角形按钮实施应用。

    推测字段：指定参考数据源里用来和辅助字段相比较的字段名称。

    附带字段：在参考数据源显示匹配记录时，显示的字段名称列表。

    字段替换关系：设置参考数据源记录的字段对表格控件的字段的一一对应替换关系。注意辅助字段和推测字段不要在这里设置为替换关系。

    保存当前辅助：如果上面设置完毕，通单击该按钮可以将辅助设置保存起来。

    撤销当前辅助：撤销当前的辅助录入设置。

    【从表计算设定】

    计算设定用来对当前从表的字段间进行记录级别上的计算。在记录被提交时触发。

    当前字段：指定进行计算公式设置的字段名称；

    计算公式：当前字段指定的字段的计算公式；计算公式除了支持常规的加减乘除运算外，还支持多种运算方式，列表如下：

四则运算 | 加减乘除及其优先级运算，支持利用括弧()改变优先级。
函数支持
函数类型 | 函数名称 | 说明 | 备注
数学函数 | tan()； |  |
 | sin()； |  |
 | cos()； |  |
 | sinh()； |  |
 | cosh()； |  |
 | arctan()； |  |
 | cotan()； |  |
 | arg()； |  |
 | exp()； |  |
 | ln()； |  |
 | log10()； |  |
 | log2()； |  |
 | square()； |  |
 | sqrt()； |  |
 | abs()； |  |
 | trunc()； |  |
 | ceil()； |  |
 | floor()； |  |
 | heaviside()； |  |
 | sign()； |  |
 | zero()； |  |
 | phase()； |  |
 | rnd()； |  |
 | random()； |  |
 | max()； |  |
 | min()； |  |
 | power()； |  |
 | IntPower() |  |
 | ；logN()； |  |
特殊函数 | $^ ； | 数字字段转货币大写 |
 | %^； | 数值字段转大写 |
 | #^DATE()； | 字段强制赋值当前日期 |
 | #^NULLDATE()； | 字段为空时，强制赋值当前日期 |
 | #^DATETIME()； | 字段强制赋值当前日期时间 |
 | #^NULLDATETIME()； | 字段为空时，强制赋值当前日期时间 |
 | @^PYM()； | 根据指定文本字段，将当前字段赋值拼音码。 |
 | @^CURUSER()； | 字段赋值当前用户名 |
 | @^NULLTRUE； | 如果字段为空，强制赋值TRUE |
 | @^NULLFALSE | 如果字段为空，强制赋值FALSE |
字符赋值 | 直接输入的任何字符可以被直接赋值给指定字段

    待选字段：在公式设置中可以引用的字段名称，可以通过双击对应字段名称使其追加到计算公式文本框；

    待选操作：计算公式可以引用的计算方式；

    保存公式：保存设置的公式，公式只有测试正确后，才能调用该功能。；

    删除公式：删除当”前字段“指定的字段名的公式计算设置；

    【从表记录验证】

    设定用于设置在记录改变时，检查是否复合设定的验证标准。验证标准本身也时一个布尔表达式，如下图所示，这里的验证基本限于数字计算相关的验证。

    四个下拉列表框分别为：字段选择列表框、运算符选择列表框、条件值录入选择列表框和后续续选择列表框，用来生成条件表达式。

    左边的列表框用来存放验证列表

    右边的文本框是用来存放验证条件的。

    增加验证按钮、保存验证和删除验证用来执行增加新的验证规则、保存设置或修改的验证规则和删除已经存在的指定的验证规则。


查询设计窗口

    在节点关联数据源采用SQL语句时，如果采用了参数，可以自定义参数窗口配合该语句的执行。在主窗口信息节点单击鼠标右键，在弹出菜单中执行“信息关联设置－创建/编辑查询窗口”，可以进入参数设置窗口。

    【查询窗口设计界面功能说明】

    窗口分为三部分：工具栏、工作区和属性条。

    工具栏：最上面的部分是工具栏，包括控件按钮和功能按钮。

        关于工具栏控件按钮

控件 按钮 | 名 称 | 功 能 | 主要属性
 | 标签 | 通常用于在界面中显示固定信息，如界面标题及某些对象的功能等 | 标题
 | 形状 | 形状控件用于在界面上制作矩形、正方形、圆角矩形、圆角正方形、椭圆形、圆形。同一种控件制作哪一种图形，这取决于对其“形状”属性的设置。 | 形状
 | 编辑框 | 编辑框是既可以输入文字，也可以输入数字字符。 | 绑定数据源 绑定参数
 | 备注文本 | 当要录入的文本较大时通常选用备注文本作为录入对象 | 绑定数据源 绑定参数
 | 列表框 | 主要用来选择一组预定的数据，当选项内容在列表区域不下时，可通过滚动条游览列表的其他选项。 | 绑定数据源 绑定参数 列表框选项
 | 日历 | 输入日期信息。 | 绑定数据源 绑定参数

        关于工具栏功能按钮

控件 按钮 | 功 能
 | 重新读入保存的查询窗口设计信息，当前的设计和修改作废。
 | 保存当前的查询窗口设计信息
 | 清除当前设计的查询窗口版面信息
 | 查询窗口面板设置信息，可以设置查询窗口大小等多种功能。
 | 复制当前选定控件，生成一个新的控件。
 | 删除当前选定控件
 | 根据当前设计的查询窗口格式显示查询窗口，便于确定设计的效果，从而改进设计。
 | 当前选定控件前移
 | 当前选定控件后移
 | 显示/隐藏属性列表

    工作区：查询窗口设计区。

    属性表：显示当前选定控件的各种属性，可以在这里修改相应的属性。

属性名称 | 说明 | 适用控件
标题 | 控件显示的文字内容 | 标签
左边距 | 控件距离左边的像素数值 | 所有控件
上边距 | 控件距离上边的像素数值 | 所有控件
宽度 | 控件的宽度数值，用像素做为度量单位 | 所有控件
高度 | 控件的高度数值，用像素做为度量单位 | 所有控件
文字排列 | 确定控件在文字排列对齐方式 | 标签、备注文本
自动大小 | 如果文字过多，控件宽度是否自动增大 | 标签
字体 | 控件字体设置 | 标签，编辑框，列表框
透明 | 确定控件是否透明显示 | 标签
文字绕排 | 确定控件在文字过多时是否换行排列 | 标签，备注文本
绑定数据源 | 需要关联绑定其数据参数的信息表或查询 | 数编辑框，备注文本，列表框
绑定参数 | 需要绑定的参数名称，参数列表列出当前数据源所有可用参数的名称。 | 编辑框，备注文本，列表框
刷子颜色 |  | 形状
刷子风格 |  | 形状
画笔颜色 |  | 形状
画笔方式 |  | 形状
画笔风格 |  | 形状
画笔线条宽度 |  | 形状
形状 |  | 形状
Tab顺序 | Tab键和回车键时焦点移动的顺序。 | 编辑框，备注文本，列表框
框架 | 确定控件是否有边框 | 编辑框，备注文本，列表框
滚动条 | 是否显示滚动条及其显示方式 | 备注文本
最大长度 | 最多录入的字符数 | 备注文本
列表框选项 | 待选项目，可以用SQL语句替换 | 列表框
列表框风格 | 列表框显示风格 | 列表框
背景颜色 | 控件的背景颜色 | 标签，编辑框，备注文本，列表框


批量修改节点数据源连接

    有时候在改变数据库的时候，需要对信息管理树各节点的数据源联结进行统一调整，这个时候可以使用该功能，通过主窗口主菜单：“工具－批量调整数据源联结”可以进入该窗口。

    参考外部数据源联结（联结模板）：如果信息管理树节点联结需要指向外部数据库（很多情况下如此），需要设置这个联结，然后将这个联结做为模板，在下面的功能中引用。

    指定当前的操作节点：如果修改联结只是针对某个节点进行，那么请选定对应的节点。

    当前节点数据源：显示当前节点的数据源。

    当前数据源明细：以多行的形式显示当前“当前节点数据源”列表中选定的数据源内容。可以进行修改，系统会保存修改内容。

    当前数据源联结：显示当前“当前节点数据源”列表中选定的数据源对应的数据联结的详细内容，可以修改，系统会保存修改内容。

    进行验证：如果该项选定，系统在更改联结后会尝试执行该联结，如果联结没有通过，会给出联结异常提示。

    内部联结：将当前节点的数据源联结改为内部联结。

    模板联结：将当前节点的数据源联结改为上面设定的模板联结。

    应用：保存上面执行的“内部联结”或模板联结。

    全部模板联结：针对所有的节点都设置为上面的模板联结，并且自动保存。

    全部内部联结：针对所有的节点都设置为内部联结，并且自动保存。


计算处理窗口

    信息处理基本可以分为两种，基于信息单元的信息处理和基于整个信息管理系统的信息处理。前者包括：字段批量计算、记录计算与验证、序列填充、触发器和关联数据源时的SQL语句信息处理；后者主要是指“运算树信息增强处理”。

    本节主要说明运算树信息增强处理的使用方法。

    【进入计算处理窗口】

    在系统菜单，选择“工具－运算树信息增强处理”，或在工具栏上单击 [image] 按钮，即可进入计算处理窗口。

    【功能说明】

    运算树选择列表：系统中已经创建的运算树都会在这个下拉列表框中，通过选择对应的运算树名称，可以打开对应的运算树。

    增加按钮：单击可以增加新的运算树，系统要为新创建的运算树输入一个名称，然后系统会在运算树选择列表自动创建指定的运算树。

    删除按钮：删除运算树选择列表当前选定的运算树。

    运算树：显示和设置运算树选择列表当前选定的运算树，可以通过右键菜单增加各级节点，包括处理节点和析取节点。每个处理节点可以设置一个或多个SQL语句，SQL语句存放在右边的“SQL语句文本框”。每个析取节点可以设置一个数据赋值列表，通过“数据析取列表”设置。

    参数列表：设置针对当前处理节点执行的SQL语句(组)中参数获取途径的方式。如果在SQL语句中引用了参数，可以通过设置参数列表来指明各个参数的获得具体值的方式。涉及四个方面：参数、表、字段、筛选条件，参数是SQL语句中的参数名称，表是指这个参数的值到哪个信息表中去查找，字段是指取哪个字段的值，筛选条件则是确定指定信息表的哪个记录的指定字段值。如果SQL语句中有多个参数，则需要针对每个参数均进行设置。如果不设置参数，系统会在执行时弹出参数对话框。

    SQL语句文本框：放置当前处理节点的SQL语句或语句组，SQL语句可以引用参数，参数需要以冒号开头做为标识，冒号不做为参数名称的一部分，例如：

    SELECT * FROM 学生信息 WHERE 性别=":请输入性别";

    这里参数是“请输入性别”，因为性别是字符串，所以将参数用引号引起。其它例子：

    SELECT * FROM 学生信息 WHERE 年龄= :请输入年龄;　(年龄为数值型，因此不需要引号)。

    SELECT * FROM 学生信息 WHERE 出生日期= #:请输入日期#;　(出生日期为日期型，需要#括起，针对单机系统)。

    如果有多个语句，语句间要有独占一行的GO语句隔开。

    当前SQL语句数据连接：一般情况下，该项为空，标明语句在系统内的信息表中执行。如果语句是针对外部数据库执行，则需要对其进行设置。可以通过“连接选择类别”选择即可。

    复制到整个运算树按钮：如果希望将当前语句的连接快速复制到本运算树的所有节点，则单击该按钮即可实现。

    数据析取列表：针对析取节点进行设置，确定复制的源目标（表－字段－筛选条件）和复制到的目的目标（表－字段－筛选条件）。

    析取来源连接和析取目标连接：分别设定源目标的数据源连接和目标数据源连接，可以分别通过来源连接选择列表和目标连接选择类别进行设定，如果操作的是对系统内部表，默认为空即可。

    执行当前节点按钮：执行当前节点设定的处理或者析取操作。

    执行当前节点和子节点按钮：执行当前节点及其子节点设定的处理或者析取操作。

    执行处理树按钮：从第一个节点开始执行当前树所有的节点。


SQL命令窗口

    有时有一些特殊的、偶尔的数据处理需求，没有必要在信息节点或者运算树中实现，这时可以使用SQL命令窗口。

    通过主窗口主菜单：“工具－SQL命令窗口”，可以进入该窗口。

      数据来源：SQL命令窗口可以执行针对系统内部的信息处理语句，也可以执行针对外部数据库的SQL语句，如果是前者，数据来源选择“系统内部”，反之，选择“系统外部”，如果选择系统外部，需要设置其右面的外部数据源联结信息，通过“...”按钮进行设置即可。

    SQL语句：希望执行的SQL语句或SQL语句系列，如果是多个语句，语句之间要用GO单行隔开。

    SQL语句执行信息：对于有返回记录的SQL语句，显示返回的结果集。

    执行SQL语句：执行上面设置的SQL语句，如果语句有返回记录集，则在“SQL语句执行信息中显示”，语句如果执行成功，则提示“执行完毕！”，如果没有成功执行，则给出异常信息。


自动事务

    系统的自动事务功能用来动态执行处理功能和实现基于系统数据的事务提醒功能。如果希望使用自动事务功能，需要在选项中进行设置，以启动系统的自动事务功能。

    【自动事务设置】

    在主窗口，通过执行菜单：工具－选项，即可进入选项设置窗口，选择“自动事务”页。

    【自动事务项目设置】

    通过事务数据记录导航条可以增加、修改、删除自动事务，自动事务可以有多个，一个自动事务包括如下项目：

    事务名称：标识事务的名称。

    用途说明：描述该事务的用途意义，便于以后维护管理。

    事务类型：分为自动执行和执行提示两种，前者用于动态处理数据，后者可以在具有前者功能的前提下根据最终的执行SQL语句是否包含记录来确定是否产生提示事件。

    用户提示：针对执行提示的事务类型，当用户打开事务提示窗口时，该事务提示用户的内容。

    SQL语句(组)：指定进行数据处理和用户提示判定的SQL语句或语句组，如果时语句组，SQL语句之间请用GO单行隔开，对于执行提示类型的事务，系统以最后执行的语句是否含有记录来判定是否产生提示事件。

    适用用户：设定该自动事务的适用用户列表，如果为空则默认适用于所有用户，否则适用与指定的用户列表，可以适用右边的待选用户列表来增加用户。

    执行周期：设定当前自动事务动态执行的周期，以秒为单位，用户可以根据实际应用需要和系统繁忙程度设置合适数值。

    启动功能代码：在“自动事务提示窗口”中当用户双击该事务或者执行“查看选定事务”按钮时，系统自动执行的功能代码。获得该功能码的方式如下：

    １、功能码必须以“@”开始；

    ２、功能码的第二个字母不同意义不同：

功能码第 2个字母 | 代表的信息类型
T | 调用信息管理树的节点关联的信息单元项目，例如表格界面、录入窗口、报表、分析等。
F | 调用数据处理。
E | 调用自动交换。
O | 打开指定的外部文件，系统根据外部文件的类型自动启动对应的程序。
M | 调用系统主窗口的菜单项目。

    3、如何确定调用的详细信息：

    系统在主窗口工具菜单下提供了“创建Web面板”子菜单功能，用来生成当前信息管理系统的针对每个节点的表格界面、录入窗口报表、分析等的功能码调用方式。可以利用这个网页来获得对应的功能码。

    数据处理调用格式为：@F:<数据处理名称>

    自动交换调用格式为：@E:<自动交换名称>

    外部文件调用格式为：@O:<外部文件路径名称>

    菜单调用格式为：@M:<菜单名称>

    当前自动事务有效：确定当前事务是有效状态还是无效状态，无效时不会被执行和触发提示事件（执行提示类型）。

    系统启动时自动打开提示窗口：在系统启动后，如果自动事务发现有符合条件的提醒时，根据该选项确定是否直接打开事务提示窗口。

    如果事务通过导航栏按钮被修改和保存，下面的取消按钮无效。

    【事务提示和处理】

    自动事务在设置后，系统根据设置在后台动态执行和判断是否需要提示（执行提示类事务），如果有自动事务复合提示条件，系统会在主窗口下面的状态栏的左边不断闪动提示。用户单击该处即可打开“自动事务提示窗口”，如下图：

    该窗口功能说明如下：

    窗口的上面部分显示提示的事务列表，包括触发提示事件的事务的事务名称、说明等信息。如果事务执行出现异常，异常信息出现在备注栏中。

    查看选定事务按钮：根据选定事务指定的功能码，执行对应的功能。

    禁止选定事务按钮：将当前选定事务禁止触发提示，该设置只在本次系统启动有效，退出系统后即失效。

    解禁选定事务按钮：将当前选定事务恢复触发提示，该设置只在本次系统启动有效，退出系统后即失效。


与EXCEL文件交换数据

    系统支持和EXCEL文件进行数据交换，在主窗口，可以通过在当前节点（选中节点）单击鼠标右键，执行弹出菜单：“表格界面－>与EXCEL文件交换数据”可以进入与EXCEL文件交换数据窗口。

    【选定表格】

    无论是导出数据到EXCEL还是从EXCEL表格中导入数据，都需要指定表格，表格一般是主表，如果是某个从表，请从该处指定。

    【表格界面数据到EXCEL文件】

    工作表名：设置导出的EXCEL文件SHEET的名字，默认为“来自表格的数据”。

    开始按钮：自动创建EXCEL文件，并创建指定的工作表名称，然后将指定表格的数据导入的这个工资表中。

    【EXCEL文件数据到表格界面】

    EXCEL文件：通过单击其右面的按钮，可打开文件对话框，供用户选择需要导入的EXCEL文件。

    工作表：指定需要导入的工作区表名称，直接从下拉列表中选择即可。

    字段对应：显示系统内表格界面和EXCEL文件的字段对应关系。因为EXCEL是非数据库格式的数据，因此在导入时，系统尝试将其转换为数据表格式进行导入，EXCEL的数据格式越倾向于数据表，越容易导入。这里会将两种数据的字段对应关系自动匹配，如果字段名不同，需要用户从下拉列表中选择字段名称手工进行匹配。

    开始按钮：按照上面的设置进行导入操作。如果操作过程中出现格式转换问题，例如字符类型导入到数值类型，系统会出现提示，并停止导入。


信息导出和导入

    很多情况下需要将系统数据传给使用相同系统的其它用户，比如向上机部门传送数据等，这可以通过系统的导出导入功能实现。系统采用传送包的概念实现相同系统的信息交换。通过信息导出生成一个数据传送包，然后可以通过多种方式将数据传送包文件送给其他相同系统的用户，例如网络、邮件、磁盘等。然后其他用户利用信息导入功能将传送包的数据分别导入自身的系统中。

    【信息导出】

    在主窗口执行菜单功能：工具－信息交换－信息导出，即可进入信息导出窗口。

    传送包：指定传送包的位置，可以通过右边的查找按钮打开文件对话框以确定已经存在的传送包的位置，也可以通过新建按钮创建新的传送包。

    导出类型：可以导出当前节点（选中节点）主表的当前记录、当前内容（如果已经筛选，则是筛选后的内容）和当前信息表三种类型。

    导出信息表名：确定导入到传送包中的信息表的名称，传送包可以存放多个信息表，信息表的名字不能重复。

    导出信息按钮：单击该按钮，系统执行设定的操作，将数据导入到传送包中，并显示在系统下边的列表框中。

    如果同一个信息表需要重新导入，请在下面的列表框中使用右键菜单删除对应信息表后重新导入。

    【信息导入】

  在主窗口执行菜单功能：工具－信息交换－信息导入，即可进入信息导入窗口。

    传送包：指定传送包的位置，可以通过右边的查找按钮打开文件对话框以确定已经存在的传送包的位置。

    选定将要导入的信息表：用鼠标在列表框中显示的当前传送包中的信息表列表中选择需要导入的信息表。注意，信息将被导入到当前节点（选中节点）的主表中。

    导入到当前信息主表按钮：单击该按钮，系统执行设定的操作，将数据导入到当前节点的主表中。


自动交换

    自动交换用于在系统内部信息表之间、系统内部和系统外部信息表之间、系统外部的信息表之间进行一系列的自动信息交换。

    【进入自动交换设置窗口】

    在主窗口，通过执行菜单：工具－信息交换－自动交换设置，即可进入自动交换设置窗口。

    【数据交换组】

    数据交换组做为数据交换的一个分类单位包括一个以上的数据交换设置。，一个数据交换组会在菜单上生成一个菜单项，用户通过执行该菜单项，即可执行该交换组中的所有数据交换设置。

    通过“数据交换组”右面的增加按钮可以增加新的交换组，通过右面的“删除当前组”按可以删除数据交换组下拉列表框选择的当前交换组。

    通过数据交换组下拉框可以选择已有的交换组做为当前交换组，系统会在下面显示其包含的数据交换列表。

    【当前交换组数据交换列表】

    包括当前数据交换组的数据交换列表，可以选定某个数据交换做为当前的数据交换，从而进行设置，也可以通过右边的增加按钮增加新的数据交换到交换列表。通过“删除当前交换”按钮可以将当前交换删除。

    【数据交换设定】

    只要包括三部分：设定源数据、设定目标数据源、设定源数据和目标数据的字段对应关系。

    设定源数据：源数据是指数据交换操作中提供数据的来源，通过单击源数据框内的“设置”按钮，可以进入源数据设置窗口，如下图：

    该窗口功能说明如下：

    数据来源：系统内部和系统外部，外部需要设定数据源，单击其“...”按钮可以进行设置，一般是指定驱动和设置路径和登录用户名等信息，设置完毕做为连接字符串放置到“外部数据源”编辑框中。

    数据表名称和查询语句：可以采用数据表或者查询语句的方式提供数据，设置后会在下面显示数据内容，用来确定设置的效果。

    设置完毕后，通过点击确定按钮即可关闭当前窗口，返回数据交换窗口，系统自动将设置的连接字符串和选择的数据源信息（表或查询）放置到“源数据”框内的数据连接和数据源编辑框中。

    设定目标数据源：目标数据是指数据交换操作中获得数据的数据源，通过单击目标数据框内的“设置”按钮，可以进入目标数据设置窗口，设置方式同源数据相同，不在说明。实表访问选项一般情况下建议选定，这样可以在进行替换方式的交换是避免出现“记录无法定位”等类似错误。

    字段对应：设定源数据和目标数据的字段对应关系，系统会根据两个数据的字体名称自动匹配，如果字段名字不相同，需要用户手工匹配。

    【数据交换方式】

    数据交换有两种方式：直接追加和比对替换。

    直接追加：数据以新记录的方式追加。

    对比替换：根据某些字段比对两个数据源中是否有相同的记录，如果有则可以选择替换或跳过（根据“比对相同是否跳过”选项是否选定确定），否则追加新记录。

    两种方式采用哪种要看“直接追加”选项是否被选定，如果选定则采用直接追加方式，否则采用对比替换方式。

    【保存当前交换按钮】　保存当前数据交换的所有设置。

    【执行当前交换按钮】　执行当前数据交换

    【执行当前交换组按钮】　执行当前交换组中的所有交换设置。


信息表交换

    信息表交换用来实现在不同的信息管理系统数据库之间进行信息表（数据表）的复制。

    在主窗口，通过主菜单：“工具－信息表交换”可以进入信息表交换窗口。

    外部数据：用来和信息管理系统进行数据交换的外部数据库连接信息，通过“打开”按钮可以进行设置，设置好的连接信息保存在外部数据编辑框中，同时在“外部数据源信息表”列表框中显示外部数据库的信息表（数据表）列表。

    本系统信息表：系统内部信息表列表，如果“显示系统表”被选定，则系统表名称也会被显示，同时可以用来进行交换操作。

    外部数据源信息表：显示外部数据库的信息表列表。

    如果希望重新导入已经存在的表，请在列表框上使用右键菜单删除计划导入的表，否则无法导入。

    “<<=”和“=>>”按钮，用来执行导入导出功能。


转换到新的数据库

    如果希望将已经设计好的系统转换到新的数据库中，例如有单机系统转换到SQL SERVER数据库，可以使用“转换到新的数据库”功能，该项功能也可以用来进行数据备份，例如把基于SQL SERVER数据库的系统以单机文件的方式备份。

    注：在单机应用系统中，该功能是不可用的。

    在主窗口，通过调用菜单功能：“工具－转换到新的数据库”，可以进入该窗口。

    【新的数据库连接】

    指定希望转换到的数据库的连接信息，希望转换到的数据库必须已经存在，针对单机数据库，请使用相应的程序创建空的数据库，针对SQL SERVER等大型数据库，请使用SQL语句（CREATE DABABASE等）创建数据库，或者通过其相关的管理工具创建。如果使用SQL语句创建，可以在工具菜单的“SQL命令窗口”进行操作。

    系统会根据您指定的数据库连接自动升迁到指定的数据库，并且会根据您指定的名字创建一个连接配置文件，可以通过打开该文件访问您新升迁到的数据库，包括所有的设计功能、数据和权限等。该操作不会影响当前已经存在系统系统，您仍然可以按照原来的方式访问当前的系统，这两个系统是彼此独立的。

    【开始转换按钮】

    执行该按钮系统开始完整转换操作，需要用户指定一个连接文件的名称，然后系统自动完整转换。用户可以通过DCN连接文件访问转换后的新系统。


转换Access数据库

    本功能可将Access数据库(*.mdb)文件转换为基于平台的信息库(*.dbi)文件，该操作将产生一个新的dbi文件，不会对原Access数据库进行任何更改。

    在主窗口，通过执行菜单：“工具－转换Access数据库”，可以进入该转换窗口：

    通过单击浏览按钮，可以打开需要转换的ACCESS数据库。

    单击“开始生成信息库(dbi文件)”按钮，可以执行转换功能，系统会弹出对话框要求为信息框文件指定存放路径和名称，然后会显示转换进度。

    系统在转换完毕后会提示进入转换后的信息库管理系统。

    转换只是保留Access的信息表和根据信息表创建信息管理树，同时创建一些系统表。转换并不包括Access的窗体、报表等功能模块。


浮动命令面板

    浮动命令面板被设置做为引导用户操作的命令导航，它悬浮在主窗口的上方，可以通过主窗口工具栏显示隐藏命令面板按钮 [image] 来显示和隐藏。命令面板并不是必须的。

    通过以下方式可以进入浮动命令面板设置操作，主菜单“工具－设计操作向导”。

    【命令面板列表窗口】

    启用命令面板：系统初次使用命令面板需要执行该按钮的功能。只有启用命令面板，系统才会在启动后自动显示该面板。

    删除命令面板：如果相取消面板功能，使用该按钮，系统将清除系统内所有已经存在的面板，窗口下面的列表和按钮将被禁止使用，并在系统启动时取消显示功能。

    在启用命令面板后，可以使用下面的各个功能。

    命令面板列表：显示当前系统所有可用的命令面板名称列表，可以用鼠标选定一个命令面板名称，然后可以进行设计、改名和删除等操作。

    创建命令面板按钮：创建一个新的命令面板，系统会提示为新面板确定一个名称，然后会将该空白的命令面板追加到命令面板列表。

    设计选定面板按钮：打开在命令面板列表选定的命令面板进行设计，系统会打开“命令面板设计窗口”，供开发者进行设计。

    选定面板改名按钮：对在命令面板列表选定的命令面板进行改名操作。

    删除选定面板按钮：对在命令面板列表选定的命令面板进行删除操作。

    设定为主面板按钮：将在命令面板列表选定的命令面板做为主面板，这样系统在启动时就会首先打开该面板。

    如果设计了命令面板，窗口会显示如下：

    【命令面板设计窗口】

    在上面的窗口的命令面板列表中选择一个面板，然后单击“设计选定面板”，会进入命令面板设计窗口。

    命令面板支持对系统多个方面的功能调用，包括：操作（指定节点的表格界面、录入窗口、报表、分析）、信息处理、数据交换、其它命令面板、主窗口菜单。命令面板通过设置功能区和显示控件两种方式绑定功能调用。显示控件包括：标签、形状、固定图形，显示控件的属性可以通过右侧的属性列表来设置。

    窗口左面是供功能区设置和显示控件绑定的功能模块，可以通过“功能”选项来确定希望配置的功能类型，然后再进行向下确定。

    下面详细说各个部分的功能：

    工具栏：包括功能区按钮、显示控件按钮和功能按钮。

    功能区和显示按钮：

控件 按钮 | 名 称 | 功 能 | 主要属性
 | 功能区 | 在背景图形上设置一个热点区域，绑定指定的功能，用户可以通过点击该区域访问设定的功能。 | 提示 隐藏边框
 | 标签 | 在面板上设置文字提示，显示固定信息。可以绑定功能模块。 | 标题
 | 形状 | 形状控件用于在面板上制作矩形、正方形、圆角矩形、圆角正方形、椭圆形、圆形。同一种控件制作哪一种图形，这取决于对其“形状”属性的设置，可以绑定功能调用。 | 形状
 | 背景图形 | 面板的背景图形，系统要求任何命令面板均需要背景图形，系统根据背景图形的大小确定其显示大小。 |
 | 固定图形 | 在面板放置固定的图形，可以绑定功能调用。 |

    功能按钮：

控件 按钮 | 功 能
 | 重新读入保存的命令面板设计信息，当前的设计和修改作废。
 | 保存当前的命令面板设计信息
 | 清除当前设计的命令面板信息
 | 复制当前选定控件，生成一个新的控件。
 | 删除当前选定控件
 | 当前选定控件前移
 | 当前选定控件后移
 | 显示/隐藏属性列表

    属性表：显示当前选定控件的各种属性，可以在这里修改相应的属性。

属性名称 | 说明 | 适用控件
标题 | 控件显示的文字内容 | 标签，检查框
左边距 | 控件距离左边的像素数值 | 所有控件
上边距 | 控件距离上边的像素数值 | 所有控件
宽度 | 控件的宽度数值，用像素做为度量单位 | 所有控件
高度 | 控件的高度数值，用像素做为度量单位 | 所有控件
文字排列 | 确定控件在文字排列对齐方式 | 标签
自动大小 | 如果文字过多，控件宽度是否自动增大 | 标签，图形
字体 | 控件字体设置 | 标签
透明 | 确定控件是否透明显示 | 标签
文字绕排 | 确定控件在文字过多时是否换行排列 | 标签
刷子颜色 |  | 形状
刷子风格 |  | 形状
画笔颜色 |  | 形状
画笔方式 |  | 形状
画笔风格 |  | 形状
画笔线条宽度 |  | 形状
形状 |  | 形状
背景颜色 | 控件的背景颜色 | 标签、图形
提示 | 当用户将鼠标放置其上时，显示的提示内容 | 所有控件

    窗口左侧是可以被命令面板调用功能模块。根据对“功能”选择的不同选择，下面对应显示不同的界面。在工作区设置功能分配时，可以选定指定的功能区或者一个显示控件，然后在左侧通过选择的方式实现功能调用指定。

    操作：显示主窗口的信息管理树，针对每个节点会显示对应的表格界面、录入窗口、报表输出和信息分析供选择。如果选择的是录入窗口、报表或分析，而且存在多个，需要从对应下拉框中进行进一步选择。

    处理：在下拉列表显示当前可用的处理名称列表，用户可以指定需要执行的处理调用。

    面板：在下拉列表显示当前可用的面板名称列表，用户可以指定需要调用其它面板调用。

    交换：在下拉列表显示当前可用的交换名称列表，用户可以指定需要执行的交换调用。

    菜单：以树形目录的方式显示系统当前所有可用的主菜单项目，可以通过选定某个菜单项，来指定需要调用的功能。


背景命令面板

    背景命令面板是放置在系统主窗口信息显示区的一个或多个网页组成。网页除了具有一般网页在浏览器中的功能还支持系统设定的一系列格式，用来调用系统的各项功能。

    网页可以通过两种方式被设置为背景命令面板：一、首页文件名字固定为“background.htm”，并且和应用系统在同一个文件夹下。二、通过信息节点关联设置，设置为非数据库格式连接，并关联首页文件名称，需要说明的是，这种方式只对设置的节点有效。

    背景命令面板也可以通过主窗口工具栏显示隐藏命令面板按钮来显示和隐藏。

    【设计网页】

    当前设计网页的工具很多，大家可以根据自己的情况选择。设计的关键是要清除如何设置可以调用系统的各种功能。每次用户单击网页连接时，系统都要对连接地址进行分析，如果连接复合调用系统内部功能的标准则依据其信息调用执行系统功能。

    【设置调用系统功能的连接信息】

    标准如下：

    １、连接信息（<a href="..."></a>中引号中的信息）必须以“@”开始；

    ２、连接信息的第二个字母不同意义不同：

连接信息第 2个字母 | 代表的信息类型
T | 调用信息管理树的节点关联的信息单元项目，例如表格界面、录入窗口、报表、分析等。例如：@T:8:I:1
P | 除和“T”信息相同外，还支持传递参数，参数格式为Para(参数名称1:参数值1,...)，参数名称和参数类型要和调用的节点对应的SQL语句中的参数一致，例如：@P:8:I:1:Para(ID:22,学籍号:'03')
F | 调用数据处理。
E | 调用自动交换。
O | 打开指定的外部文件，系统根据外部文件的类型自动启动对应的程序。
M | 调用系统主窗口的菜单项目。

    3、如何确定调用的详细信息：

    系统在主窗口工具菜单下提供了“创建Web面板”子菜单功能，用来生成当前信息管理系统的针对每个节点的表格界面、录入窗口报表、分析等的WEB连接调用方式。可以利用这个网页来指导设置自己的背景命令面板调用方式。

    数据处理调用格式为：@F:<数据处理名称>

    例如：<a href="@F:数据处理示例">单击调用数据处理示例</a>

    自动交换调用格式为：@E:<自动交换名称>

    例如：<a href="@E:自动交换示例">单击调用自动交换示例</a>

    外部文件调用格式为：@O:<外部文件路径名称>

    例如：<a href="@O:Operation.chm">单击调用业务帮助文件</a>

    菜单调用格式为：@M:<菜单名称>

    这里菜单名称为具体需要执行的菜单项的名字，例如调用帮助菜单下的“关于”菜单，其菜单名称为："MemuAbout",则连接信息为：<a href="@M:MemuAbout"></a>

    这里以菜单调用为例，完整网页示例源码如下：

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=gb2312">
<title>无标题文档</title>
</head>

<body>
<a href="@M:MemuAbout">单击调用关于菜单</a>
</body>
</html>


修改系统的显示风格

    【设置闪屏】

    系统在启动时进入主窗口之前显示的画面就是系统的闪屏。

    用户可以根据需要更改这个闪屏，闪屏本身是一个图片，为JPG格式，自定义闪屏要求使用文件名：Splash.jpg,并且放在系统所在的文件夹下，关于菜单也采用这个闪屏做为显示内容。

    如果系统的文件夹下已经存在Splash.jpg文件，直接覆盖即可。

    【设置系统帮助文件】

    系统帮助文件的名字为：SysHelp.chm，主要提供开发相关的信息。如果希望显示其它的资料，请自己创建一个同名帮助文件覆盖该文件即可。如果删除该文件，帮助菜单的“系统帮助”菜单项将不会显示。

    【设置业务帮助文件】

    业务帮助文件的名字为：Operation.chm,主要提供和管理系统业务相关的信息。如果希望显示其它的资料，请自己创建一个同名帮助文件覆盖该文件即可。如果删除该文件，帮助菜单的“业务帮助”菜单项将不会显示。

    【创建调用外部程序的菜单】

    创建一个文本文件，命名为： OutApp.oap ，在其内可以填写调用的外部程序的路径和名称，一行一个调用。(如果希望菜单显示文字说明的标题，可以在行的开头标明显示文字，然后紧跟";"，其后再描述调用内容。)然后将该文件复制到系统的安装文件夹即可。系统会出现“外部程序”菜单项目。

    【设置注册信息】

    在帮助菜单下通过“用户注册”可以进入注册窗口，该窗口主要提供用户如何注册的信息，该信息保存在系统文件夹下的Reg.txt文本文件中，用户如果希望显示其它的信息，请修改该文件。

    【修改“日积月累”】

    日积月累主要提供和系统操作相关的一些基本知识和技巧，该信息保存在系统的DayHint.txt文本文件中，如果用户认为不合适或者希望增加更多的信息，请修改该文件。

    【修改系统背景】

    系统背景是一个网页文件，名字为：background.htm或命名为主文件名和信息库文件（或连接文件）主文件名相同的.htm文件（后者在对应的信息库或连接文件打开时优先于于background.htm被采用）,您可以通过修改该文件修改背景显示，如果删除该文件，将取消背景显示。

【系统显示风格设置】

    选择系统的显示风格，系统通过选择不同的风格文件（*.skn）来呈现不同的风格，实现风格的多样化。风格文件(*.skn)文件一般随系统提供，可以到宏达公司网站下载更多的风格文件。

【设置系统程序图标】

    将希望使用的图标文件改名为Default.ico或以信息库（*.dbi）的主文件名做为图标文件(*.ico)的主文件名,然后放置在和系统文件同一个文件夹中即可，建议使用后一种方法，这样如果同一个文件夹中有多个信息库文件，就可以配置不同的图标文件，只要使图标文件的主文件名和对应的信息库文件的主文件名称一致即可。


设置系统选项

    系统的很多显示和功能选项通过一个选项设置窗口实现，超级用户通过主窗口菜单：“工具－选项”可以进入该窗口。

    【全局设置】

    系统标题：设置在系统的标题栏上显示的内容。

    隐藏信息管理树：确定信息管理树是否显示，如果不显示，可以通过菜单或者命令面板实现对系统的操作。

    隐藏录入窗口/报表/分析节点:确定在信息管理树内是否显示录入窗口、报表和分析的节点，默认显示。

    启动时隐藏命令面板：确定系统启动时是否显示浮动命令面板，默认显示。

    屏蔽开发功能：确定是否允许用户进行开发，非超级用户自动禁止开发功能。

    退出时提示备份：确定退出时是否提示“是否备份？”，进行该设置可以确保用户及时备份数据，避免损失。

    数据默认为编辑状态：确定表格界面、录入窗口的数据是否默认为可编辑状态，默认设置为可编辑状态，此时可以直接进行修改和追加（设置只读或禁止追加时除外），如果该项不被选定，则需要点击数据导航条上的“编辑按钮”或单击“插入按钮”才能进行编辑，否则对于表格会默认为只读状态，对于录入窗口，录入的信息将不能保存，并会提示“当前状态不是编辑或插入状态”，在录入窗口，可以通过按下“ESC”键来取消非编辑状态下的数据录入。

    【菜单配置】

    网站网址：设定在帮助菜单中“访问我们的网站”菜单项被执行时打开的网址。

    邮件地址：设定在帮助菜单中“邮件联系我们”菜单项被执行时使用的邮箱地址。

    隐藏注册窗口调用：确定是否在帮助菜单中显示“用户注册”菜单项。

    启动时生成业务菜单：确定系统启动时是否生成业务菜单。

    【系统显示风格设置】

    选择系统的显示风格，系统通过选择不同的风格文件（*.skn）来呈现不同的风格，实现风格的多样化。风格文件(*.skn)文件一般随系统提供，可以到宏达公司网站下载更多的风格文件。

    【登录设置】

    登录窗口显示用户列表：默认情况下，在启动用户权限设置后，系统启动登录的窗口中，用户名是需要输入的，这样在安全性上更高些，如果选定该选项，用户名将以下拉列表框的方式出现，方便了用户选择和登录，缺点是所有的用户名称会都暴露在使用者面前。

    登录提示：登录窗口的提示文字，默认为：“(默认用户为Admin,口令为空)”。

    【启动执行】

    存储过程：存放在系统启动时，在出现登录窗口（如果启动用户权限的话）之后且主窗口出现之前执行的SQL语句系列。

    创建/编辑参数窗口：创建或者编辑针对存储过程的参数窗口，该窗口在系统启动登录窗口（如果启动用户权限的话）之后且主窗口出现之前执行的SQL语句系列是执行，以便于用户指定参数值。

    清除参数窗口：清除已经设定的参数窗口。

    测试过程：测试存储过程，以便发现问题和改进过程语句。


SELECT语句

    从数据库中检索行，并允许从一个或多个表中选择一个或多个行或列。虽然 SELECT 语句的完整语法较复杂，但是其主要的子句可归纳如下：

    SELECT 列或表达式列表
    [ INTO 新表名 ]
    FROM 源表名
    [ WHERE 搜索条件 ]
    [ GROUP BY 分组列或表达式 ]
    [ HAVING 搜索条件 ]
    [ ORDER BY 要排序的列名 [ 升序 | 降序 ] ]

    由于 SELECT 语句的复杂性，下面按子句说明个别典型的语法元素和参数：

SELECT 子句
    指定由查询返回的列。

语法
    SELECT 列或表达式列表

参数
    列或表达式列表

    为结果集选择的列。每个列或表达式之间是以逗号分隔的。表名与字段名之间用“.”号分开

示例
    SELECT 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒底线库存, [警戒底线库存]-[当前库存] AS 短线数量
    FROM 货品信息表
    WHERE ((([警戒底线库存]-[当前库存])>0));

INTO 子句
    创建新表并将结果行从查询插入新表中。

    用户若要执行带 INTO 子句的 SELECT 语句，必须在目的数据库内具有 CREATE TABLE 权限。SELECT...INTO 不能与 COMPUTE 子句一起使用。

    通过在 WHERE 子句中包含 FALSE 条件，可以使用 SELECT...INTO 创建没有数据的相同表定义（不同表名）。

语法
    [ INTO 新表名 ]

参数
    新表名

    根据选择列表中的列和 WHERE 子句选择的行，指定要创建的新表名。新表名 的格式通过对选择列表中的表达式进行取值来确定。新表名 中的列按选择列表指定的顺序创建。新表名 中的每列有与列或表达式列表中的相应表达式相同的名称、数据类型和值。

    当选择列表中包含计算列时，新表中的相应列不是计算列。新列中的值是在执行 SELECT...INTO 时计算出的。

示例
    SELECT 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒底线库存, [警戒底线库存]-[当前库存] AS 短线数量
    INTO 123
    FROM 货品信息表
    WHERE ((([警戒底线库存]-[当前库存])>0));

FROM 子句
    指定从其中检索行的表。需要 FROM 子句，除非选择列表只包含常量、变量和算术表达式（没有列名）。

语法
    FROM 源表名

参数
    源表名

    指定用于 SELECT 语句的表、视图、派生表和联接表。

示例
    SELECT 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒底线库存, [警戒底线库存]-[当前库存] AS 短线数量
    FROM 货品信息表
    WHERE ((([警戒底线库存]-[当前库存])>0));

WHERE 子句
    指定用于限制返回的行的搜索条件。

语法
    [ WHERE 搜索条件 ]

参数
    搜索条件

    通过使用谓词限制结果集内返回的行。对搜索条件中可以包含的谓词数量没有限制。

示例
    SELECT 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒底线库存, [警戒底线库存]-[当前库存] AS 短线数量
    FROM 货品信息表
    WHERE ((([警戒底线库存]-[当前库存])>0));

GROUP BY 子句
    指定用来放置输出行的组，并且如果 SELECT 子句 <列或表达式列表> 中包含聚合函数，则计算每组的汇总值。指定 GROUP BY 时，选择列表中任一非聚合表达式内的所有列都应包含在 GROUP BY 列表中，或者 GROUP BY 表达式必须与选择列表表达式完全匹配。

语法
    [ GROUP BY 分组列或表达式 ]

参数
    分组列或表达式

    是对其执行分组的表达式。分组列或表达式　可以是列或引用列的非聚合表达式。在选择列表内定义的列的别名不能用于指定分组列。

示例
    SELECT 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒底线库存, Sum([警戒底线库存]-[当前库存]) AS 短线数量
    FROM 货品信息表
    GROUP BY 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒底线库存
    HAVING (((Sum([警戒底线库存]-[当前库存]))>0));

HAVING 子句
    指定组或聚合的搜索条件。HAVING 通常与 GROUP BY 子句一起使用。如果不使用 GROUP BY 子句，HAVING 的行为与 WHERE 子句一样。

语法
    [ HAVING 搜索条件 ]

参数
    搜索条件

    指定组或聚合应满足的搜索条件。当 HAVING 与 GROUP BY ALL 一起使用时，HAVING 子句替代 ALL。

在 HAVING 子句中不能使用 text、image 和 ntext 数据类型。

示例
    SELECT 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒底线库存, Sum([警戒底线库存]-[当前库存]) AS 短线数量
    FROM 货品信息表
    GROUP BY 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒底线库存
    HAVING (((Sum([警戒底线库存]-[当前库存]))>0));

ORDER BY 子句
    指定结果集的排序。除非同时指定了 TOP，否则 ORDER BY 子句在视图、内嵌函数、派生表和子查询中无效。

语法
    [ ORDER BY 要排序的列名 [ 升序 | 降序 ] ]

参数
    要排序的列名 [ 升序 | 降序 ]

    指定要排序的列。可以将排序列指定为列名或列的别名（可由表名或视图名限定）和表达式，或者指定为代表选择列表内的名称、别名或表达式的位置的负整数。

    可指定多个排序列。ORDER BY 子句中的排序列序列定义排序结果集的结构。

    ORDER BY 子句可包括未出现在此选择列表中的项目。然而，如果指定 SELECT DISTINCT，或者如果 SELECT 语句包含 UNION 运算符，则排序列必定出现在选择列表中。

    此外，当 SELECT 语句包含 UNION 运算符时，列名或列的别名必须是在第一选择列表内指定的列名或列的别名。

示例
    SELECT 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒底线库存, [警戒底线库存]-[当前库存] AS 短线数量
    FROM 货品信息表
    WHERE ((([警戒底线库存]-[当前库存])>0))
    ORDER BY 货品信息表.单位 DESC , 货品信息表.仓库编码, 货品信息表.存放仓库 DESC , 货品信息表.当前库存;

说明

    在 ORDER BY 子句中不能使用 ntext、text 和 image 列。

    ASC

    指定按递增顺序，从最低值到最高值对指定列中的值进行排序。

    DESC

    指定按递减顺序，从最高值到最低值对指定列中的值进行排序。

    空值被视为最低的可能值。

    对 ORDER BY 子句中的项目数没有限制。然而，对于排序操作所需的中间级工作表的大小有 8,060 字节的限制。这限制了在 ORDER BY 子句中指定的列的合计大小。


INSERT语句

 nnw
INSERT语句

    将新行添加到表或视图。

语法
    INSERT [ INTO] 表名 WITH (列或表达式列表 )

参数
    [INTO]

    一个可选的关键字，可以将它用在 INSERT 和目标表之间。

    表名

    将要接收数据的表或 table 变量的名称。

    WITH (列或表达式列表)

    指定目标表所允许的一个或多个表提示。需要有 WITH 关键字和圆括号。不允许有 READPAST、NOLOCK 和 READUNCOMMITTED。

示例
    INSERT INTO 工程建设项目造价对比表 ( 公路编码, 公路名称, 段编码, 段名称, 项, 目, 节, 行次编码, 序号, 单项工程, 单位 )
    SELECT m公路编码, m公路名称, m段编码,m段名称, 工程建设项目造价对比表.项, 工程建设项目造价对比表.目, 工程建设项目造价对比表.节, 工程建设项目造价对比表.行次编码, 工程建设项目造价对比表.序号, 工程建设项目造价对比表.单项工程, 工程建设项目造价对比表.单位
    FROM 项目建设造价表


UPDATE语句

    更改表中的现有数据。

语法
    UPDATE 表名 SET { 列名 = 列或表达式列表 | DEFAULT | NULL } WHERE < 搜索条件 >

参数
    表名

    需要更新的表的名称。如果该表不在当前服务器或数据库中，或不为当前用户所有，这个名称可用链接服务器、数据库和所有者名称来限定。

    SET

    指定要更新的列或变量名称的列表。

    列名

    含有要更改数据的列的名称。列名 必须驻留于 UPDATE 子句中所指定的表或视图中。标识列不能进行更新。

    如果指定了限定的列名称，限定符必须同 UPDATE 子句中的表或视图的名称相匹配。

    列或表达式列表

    变量、字面值、表达式或加上括弧的返回单个值的 subSELECT 语句。列或表达式列表 返回的值将替换 列名 或 @variable 中的现有值。

    DEFAULT

    指定使用对列定义的默认值替换列中的现有值。如果该列没有默认值并且定义为允许空值，这也可用来将列更改为 NULL。

    WHERE

    指定条件来限定所更新的行。根据所使用的 WHERE 子句的形式，有两种更新形式：

    搜索更新指定搜索条件来限定要删除的行。
    定位更新使用 CURRENT OF 子句指定游标。更新操作发生在游标的当前位置。

< 搜索条件 >

    为要更新行指定需满足的条件。搜索条件也可以是联接所基于的条件。对搜索条件中可以包含的谓词数量没有限制。

示例
    UPDATE 标段工程决算表 SET 招标合同总价=招标合同数量*招标合同单价,实际支付总价=实际支付数量*实际支付单价 where 标段编码 =“0101”;


DELETE语句

    从表中删除行。

语法
    DELETE [ FROM ] 表名 WHERE < 搜索条件 >

参数
    FROM

    是可选的关键字，可用在 DELETE 关键字与目标 table_name、view_name 或 rowset_function_limited 之间。

    表名

    是要从其中删除行的表的名称。

    在其作用域内的 table 变量、或是将 OPENDATASOURCE 函数作为服务器名称的由四部分组成的表名（或视图名称）还可以在 DELETE 语句中作为表源使用。

    WHERE

    指定用于限制删除行数的条件。如果没有提供 WHERE 子句，则 DELETE 删除表中的所有行。基于 WHERE 子句中所指定的条件，有两种形式的删除操作。

搜索删除指定搜索条件限定删除的行。

定位删除使用 CURRENT OF 子句指定游标。删除操作在游标的当前位置发生。这比使用 WHERE search_condition 子句限定删除的行的搜索 DELETE 精确。如果搜索条件不唯一标识单行，则搜索 DELETE 删除多行。

< 搜索条件 >

    指定删除行的限定条件。对搜索条件中可以包含的谓词数量没有限制。

示例
DELETE 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒高线库存, [当前库存]-[警戒高线库存] AS 超储数量
FROM 货品信息表
WHERE ((([当前库存]-[警戒高线库存])>0));


DROP TABLE语句
DROP TABLE
删除表定义及该表的所有数据、索引、触发器、约束和权限规范。任何引用已除去表的视图或存储过程必须通过 DROP VIEW 或 DROP PROCEDURE 语句显式除去。

语法
DROP TABLE table_name

参数
table_name

是要删除的表名。

注释
DROP TABLE 不能用于除去由 FOREIGN KEY 约束引用的表。必须先除去引用的 FOREIGN KEY 约束或引用的表。

表所有者可以除去任何数据库内的表。除去表时，表上的规则或默认值将解除绑定，任何与表关联的约束或触发器将自动除去。如果重新创建表，必须重新绑定适当的规则和默认值，重新创建任何触发器并添加必要的约束。

在系统表上不能使用 DROP TABLE 语句。

如果删除表内的所有行 (DELETE tablename) 或使用 TRUNCATE TABLE 语句，则表将一直存在到被除去。

权限
默认情况下，将 DROP TABLE 权限授予表所有者，该权限不可转让。然而，sysadmin 固定服务器角色成员或 db_owner 和 db_ddladmin 固定数据库角色成员可以通过在 DROP TABLE 内指定所有者除去任何对象。

示例
A. 除去当前数据库内的表
下例从当前数据库中删除 titles1 表及其数据和索引。

DROP TABLE titles1

B. 除去另外一个数据库内的表
下例除去 pubs 数据库内的 authors2 表。可以在任何数据库内执行此操作。

DROP TABLE pubs.dbo.authors2

DROP TABLE
删除表定义及该表的所有数据、索引、触发器、约束和权限规范。任何引用已除去表的视图或存储过程必须通过 DROP VIEW 或 DROP PROCEDURE 语句显式除去。

语法
DROP TABLE table_name

参数
table_name

是要删除的表名。

注释
DROP TABLE 不能用于除去由 FOREIGN KEY 约束引用的表。必须先除去引用的 FOREIGN KEY 约束或引用的表。

表所有者可以除去任何数据库内的表。除去表时，表上的规则或默认值将解除绑定，任何与表关联的约束或触发器将自动除去。如果重新创建表，必须重新绑定适当的规则和默认值，重新创建任何触发器并添加必要的约束。

在系统表上不能使用 DROP TABLE 语句。

如果删除表内的所有行 (DELETE tablename) 或使用 TRUNCATE TABLE 语句，则表将一直存在到被除去。

权限
默认情况下，将 DROP TABLE 权限授予表所有者，该权限不可转让。然而，sysadmin 固定服务器角色成员或 db_owner 和 db_ddladmin 固定数据库角色成员可以通过在 DROP TABLE 内指定所有者除去任何对象。

示例
A. 除去当前数据库内的表
下例从当前数据库中删除 titles1 表及其数据和索引。

DROP TABLE titles1

B. 除去另外一个数据库内的表
下例除去 pubs 数据库内的 authors2 表。可以在任何数据库内执行此操作。

DROP TABLE pubs.dbo.authors2


SQL运算符

+（加）
    两个数相加。这个加法算术运算符也可以将一个以天为单位的数字加到日期中。

语法
    表达式 + 表达式

参数
    表达式

    是数字分类中任何数据类型（bit 数据类型除外）的任何有效 Microsoft? SQL Server? 表达式。

结果类型
    返回优先级较高的参数的数据类型。

示例
    UPDATE 建设项目标段工程费用汇总表 SET 标段决算金额 = [建安费支出]+[设备及工具费支出]+[工程建设其他费支出]+[预留费用支出]+[非概预算费用支出]
    WHERE 标段编码=标段的编码;
-（减）
    两个数相减。该减法算术运算符也可以从日期中减去一个以天数为单位数值。

语法
    表达式 - 表达式

参数
    表达式

    是数字分类中任何数据类型（bit 数据类型除外）的任何有效 Microsoft? SQL Server? 表达式。

结果类型
    返回优先级较高的参数的数据类型。

示例
    SELECT 货品信息表.货品编码, 货品信息表.货品名称, 货品信息表.类别, 货品信息表.型号, 货品信息表.单位, 货品信息表.仓库编码, 货品信息表.存放仓库, 货品信息表.当前库存, 货品信息表.警戒底线库存, [警戒底线库存]-[当前库存] AS 短线数量
    FROM 货品信息表
    WHERE ((([警戒底线库存]-[当前库存])>0));
*（乘）
    两个表达式相乘（算术乘法运算符）。

语法
    表达式 * 表达式

参数
    表达式

    是数字数据类型分类中任何数据类型（datetime 或 smalldatetime 数据类型除外）的任何有效 Microsoft? SQL Server? 表达式。

结果类型
    返回优先级较高的参数的数据类型。

示例
    SELECT title_id, price * 1.15 AS NewPrice
    FROM titles
    WHERE type = 'mod_cook'
    ORDER BY title_id ASC
/（除）
    用一个数除以另一个数（算术除法运算符）。

语法
    被除数 / 除数

参数
    被除数

    是要被除的数字表达式。被除数 可以是数字数据类型分类中的任何数据类型（datetime 或 smalldatetime 数据类型除外）的任何有效 Microsoft? SQL Server? 表达式。

    除数

    除数的数字表达式。除数 可以是具有数字数据类型分类中任何数据类型（datetime 和 smalldatetime 数据类型除外）的任何有效 SQL Server 表达式。

结果类型
    返回优先级较高的参数的数据类型。

示例
    update temp set 原木工程决算单价=[原木决算金额]/[原木实际消耗总数量值] where 原木实际消耗总数量值<>0
=（等于）
    比较两个表达式（比较运算符）。当比较非空表达式时，如果两个操作数相等，则结果为 TRUE；否则结果为 FALSE。如果两个操作数中有一个或者两个都为 NULL，并且 SET ANSI_NULLS 被设置为 ON，则结果为 NULL。如果 SET ANSI_NULLS 被设置为 OFF，则当一个操作数为 NULL 时结果为 FALSE，当两个操作数都为 NULL 时结果为 TRUE。

语法
    表达式 = 表达式

参数
    表达式

    是任何有效的 Microsoft? SQL Server? 表达式。两个表达式都必须有可隐式转换的数据类型。转换取决于数据类型优先级。

结果类型
    Boolean

示例
    SELECT Sum(标段工程索赔统计表.索赔金额) AS 索赔金额 INTO temp
    FROM 标段工程索赔统计表
    WHERE (((标段工程索赔统计表.标段编码)=标段的编码));


SQL聚合函数

COUNT
    返回组中项目的数量。

语法
    COUNT ( { [ ALL | DISTINCT ] 列或表达式列表 ] | * } )

参数
    ALL

    对所有的值进行聚合函数运算。ALL 是默认设置。

    DISTINCT

    指定 COUNT 返回唯一非空值的数量。

    列或表达式列表

    一个表达式，其类型是除 uniqueidentifier、text、image 或 ntext 之外的任何类型。不允许使用聚合函数和子查询。

    指定应该计算所有行以返回表中行的总数。COUNT(*) 不需要任何参数，而且不能与 DISTINCT 一起使用。COUNT(*) 不需要 expression 参数，因为根据定义，该函数不使用有关任何特定列的信息。COUNT(*) 返回指定表中行的数量而不消除副本。它对每行分别进行计数，包括含有空值的行。

返回类型
    int

注释
    COUNT(*) 返回组中项目的数量，这些项目包括 NULL 值和副本。

    COUNT(ALL 列或表达式列表) 对组中的每一行都计算 列或表达式列表 并返回非空值的数量。

    COUNT(DISTINCT 列或表达式列表) 对组中的每一行都计算 列功表达式列表 并返回唯一非空值的数量。

示例
    INSERT INTO 仓库汇总 ( 仓库编码, 货品种类, 库存总额 )
    SELECT 货品信息表.仓库编码, Count(货品信息表.货品编码) AS 货品种类, Sum(货品信息表.库存总额) AS 库存总额
    FROM 货品信息表
    GROUP BY 货品信息表.仓库编码;
MAX
    返回表达式的最大值。

语法
    MAX ( [ ALL | DISTINCT | ] 列或表达式列表 )

参数
    ALL

    对所有的值进行聚合函数运算。ALL 是默认设置。

    DISTINCT

    指定每个唯一值都被考虑。DISTINCT 对于 MAX 无意义，使用它仅仅是为了符合 SQL-92 兼容性。

    列或表达式列表

    常量、列名、函数以及算术运算符、按位运算符和字符串运算符的任意组合。MAX 可用于数字列、字符列和 　　datetime 列，但不能用于 bit 列。不允许使用聚合函数和子查询。

返回类型
    返回类型与 列或表达式列表 相同。

注释
    MAX 忽略任何空值。

    对于字符列，MAX 查找排序序列的最大值。

示例
    SELECT MAX(ytd_sales) FROM titles
MIN
    返回表达式的最小值。

语法
    MIN ( [ ALL | DISTINCT ] 列或表达式列表 )

参数
    ALL

    对所有的值进行聚合函数运算。ALL 是默认设置。

    DISTINCT

    指定每个唯一值都被考虑。DISTINCT 对于 MIN 无意义，使用它仅仅是为了符合 SQL-92 兼容性。

    列或表达式列表

    常量、列名、函数以及算术运算符、按位运算符和字符串运算符的任意组合。MIN 可用于数字列、char 列、　　varchar 列或 datetime列，但不能用于 bit 列。不允许使用聚合函数和子查询。

返回类型
    返回类型与 列或表达式列表 相同。

注释
    MIN 忽略任何空值。

    对于字符列，MIN 查找排序序列的最低值

示例
    SELECT min(ytd_sales) FROM titles

SUM

    返回表达式中所有值的和，或只返回 DISTINCT 值。SUM 只能用于数字列。空值将被忽略。

语法

    SUM ( [ ALL | DISTINCT ] 列或表达式列表 )

参数

    ALL

    对所有的值进行聚合函数运算。ALL 是默认设置。

    DISTINCT

    指定 SUM 返回唯一值的和。

    列或表达式列表

    是常量、列或函数，或者是算术、按位与字符串等运算符的任意组合。expression 是精确数字或近似数字数据类型分类（bit 数据类型除外）的表达式。不允许使用聚合函数和子查询。

返回类型

    以最精确的 expression 数据类型返回所有表达式值的和。

表达式结果 | 返回类型
整数分类 | int
decimal 分类 (p, s) | decimal(38, s)
money 和 smallmoney 分类 | money
float 和 real 分类 | float
示例

    INSERT INTO 仓库汇总 ( 仓库编码, 货品种类, 库存总额 )
    SELECT 货品信息表.仓库编码, Count(货品信息表.货品编码) AS 货品种类, Sum(货品信息表.库存总额) AS 库存总额
    FROM 货品信息表
    GROUP BY 货品信息表.仓库编码;

VAR
    返回给定表达式中所有值的统计方差。

语法
    VAR ( 列或表达式列表 )

参数
    列或表达式列表

    精确数字或近似数字数据类型类别的表达式（bit 数据类型除外）。不允许使用聚合函数和子查询。

返回类型
    float

注释
    如果 VAR 用于 SELECT 语句中的所有项目，则结果集中的每个值都包含在计算中。VAR 可只用于数字列。空值将被忽略。

示例
    本示例返回 titles 表中所有 royalty 值的方差。

    SELECT VAR(royalty)
    FROM titles


SQL日期和时间函数

DATEADD

在向指定日期加上一段时间的基础上，返回新的 datetime 值。

语法

DATEADD ( datepart , number, date )

参数

datepart

是规定应向日期的哪一部分返回新值的参数。下表列出了 Microsoft® SQL Server™ 识别的日期部分和缩写。

日期部分 | 缩写
Year | yy, yyyy
quarter | qq, q
Month | mm, m
dayofyear | dy, y
Day | dd, d
Week | wk, ww
Hour | hh
minute | mi, n
second | ss, s
millisecond | ms

number

是用来增加 datepart 的值。如果指定一个不是整数的值，则将废弃此值的小数部分。例如，如果为 datepart 指定 day，为 number 指定 1.75，则 date 将增加 1。

date

是返回 datetime 或 smalldatetime 值或日期格式字符串的表达式。

如果您只指定年份的最后两位数字，则小于或等于"两位数年份截止期"配置选项的值的最后两位数字的数字所在世纪与截止年所在世纪相同。大于该选项的值的最后两位数字的数字所在世纪为截止年所在世纪的前一个世纪。例如，如果 two digit year cutoff 为 2049（默认），则 49 被解释为 2049，2050 被解释为 1950。为避免模糊，请使用四位数的年份。

返回类型

返回 datetime，但如果 date 参数是 smalldatetime，返回 smalldatetime。

DATEDIFF

返回跨两个指定日期的日期和时间边界数。

语法

DATEDIFF ( datepart , startdate , enddate )

参数

datepart

是规定了应在日期的哪一部分计算差额的参数。下表列出了 Microsoft® SQL Server™ 识别的日期部分和缩写。

日期部分 | 缩写
year | yy, yyyy
quarter | qq, q
Month | mm, m
dayofyear | dy, y
Day | dd, d
Week | wk, ww
Hour | hh
minute | mi, n
second | ss, s
millisecond | ms

startdate

是计算的开始日期。startdate 是返回 datetime 或 smalldatetime 值或日期格式字符串的表达式。

因为 smalldatetime 只精确到分钟，所以当用 smalldatetime 值时，秒和毫秒总是 0。

如果您只指定年份的最后两位数字，则小于或等于"两位数年份截止期"配置选项的值的最后两位数字的数字所在世纪与截止年所在世纪相同。大于该选项的值的最后两位数字的数字所在世纪为截止年所在世纪的前一个世纪。例如，如果 two digit year cutoff 为 2049（默认），则 49 被解释为 2049，2050 被解释为 1950。为避免模糊，请使用四位数的年份。

enddate

是计算的终止日期。enddate 是返回 datetime 或 smalldatetime 值或日期格式字符串的表达式。

返回类型

integer

注释

startdate 是从 enddate 减去。如果 startdate 比 enddate 晚，返回负值。

当结果超出整数值范围，DATEDIFF 产生错误。对于毫秒，最大数是 24 天 20 小时 31 分钟零 23.647 秒。对于秒，最大数是 68 年。

计算跨分钟、秒和毫秒这些边界的方法，使得 DATEDIFF 给出的结果在全部数据类型中是一致的。结果是带正负号的整数值，其等于跨第一个和第二个日期间的 datepart 边界数。例如，在 1 月 4 日（星期日）和 1 月 11 日（星期日）之间的星期数是 1。

DATEPART

返回代表指定日期的指定日期部分的整数。

语法

DATEPART ( datepart , date )

参数

datepart

是指定应返回的日期部分的参数。下表列出了 Microsoft® SQL Server™ 识别的日期部分和缩写。

日期部分 | 缩写
year | yy, yyyy
quarter | qq, q
month | mm, m
dayofyear | dy, y
day | dd, d
week | wk, ww
weekday | dw
Hour | hh
minute | mi, n
second | ss, s
millisecond | ms

week (wk, ww) 日期部分反映对 SET DATEFIRST 作的更改。任何一年的 1 月 1 日定义了 week 日期部分的开始数字，例如：DATEPART(wk, 'Jan 1, xxxx') = 1，此处 xxxx 代表任一年。

weekday (dw) 日期部分返回对应于星期中的某天的数，例如：Sunday = 1、Saturday = 7。weekday 日期部分产生的数取决于 SET DATEFIRST 设定的值，此命令设定星期中的第一天。

date

是返回 datetime 或 smalldatetime 值或日期格式字符串的表达式。对 1753 年 1 月 1 日之后的日期用datetime 数据类型。更早的日期存储为字符数据。当输入 datetime 值时，始终将其放入引号中。因为 smalldatetime 只精确到分钟，所以当用 smalldatetime 值时，秒和毫秒总是 0。

如果只指定年份的最后两位数字，则小于或等于"两位数年份截止期"配置选项的值的最后两位数字的数字所在世纪与截止年所在世纪相同。大于该选项的值的最后两位数字的数字所在世纪为截止年所在世纪的前一个世纪。例如，如果 two digit year cutoff 为 2049 （默认），则 49 被解释为 2049，2050 被解释为 1950。为避免模糊，请使用四位数的年份。

DAY
返回代表指定日期的天的日期部分的整数。

语法
DAY ( date )

参数
date

类型为 datetime 或 smalldatetime 的表达式。

返回类型
int

注释
此函数等价于 DATEPART(dd, date)。

示例
此示例返回从日期 03/12/1998 后的天数。

SELECT DAY('03/12/1998') AS 'Day Number'
GO

GETDATE
按 datetime 值的 Microsoft? SQL Server? 标准内部格式返回当前系统日期和时间。

语法
GETDATE ( )

返回类型
datetime

注释
日期函数可用在 SELECT 语句的选择列表或用在查询的 WHERE 子句中。

在设计报表时，GETDATE 函数可用于在每次生成报表时打印当前日期和时间。GETDATE 对于跟踪活动也很有用，诸如记录事务在某一帐户上发生的时间。

MONTH
返回代表指定日期月份的整数。

语法
MONTH ( date )

参数
date

返回 datetime 或 smalldatetime 值或日期格式字符串的表达式。仅对 1753 年 1 月 1 日后的日期使用 datetime 数据类型。

返回类型
int

注释
MONTH 等价于 DATEPART(mm, date)。

将 datetime 值包含在引号中。对于早期日期，可将其存储为字符数据。

YEAR
返回表示指定日期中的年份的整数。

语法
YEAR ( date )

参数
date

datetime 或 smalldatetime 类型的表达式。

返回类型
int

注释
此函数等价于 DATEPART(yy, date)。

示例


SQL数学函数

ABS
返回给定数字表达式的绝对值。

语法
ABS ( numeric_expression )

参数
numeric_expression

精确数字或近似数字数据类型类别的表达式（bit 数据类型除外）。

返回类型
返回与 numeric_expression 相同的类型。

示例
下例显示了 ABS 函数对三个不同数字的效果。

SELECT ABS(-1.0), ABS(0.0), ABS(1.0)

下面是结果集：

---- ---- ----
1.0 .0 1.0
EXP
返回所给的 float 表达式的指数值。

语法
EXP ( float_expression )

参数
float_expression

是 float 类型的表达式。

返回类型
float

示例
本示例声明一个变量，同时返回所给变量 (378.615345498) 的指数值，并附有文字说明。

DECLARE @var float
SET @var = 378.615345498
SELECT 'The EXP of the variable is: ' + CONVERT(varchar,EXP(@var))
GO

下面是结果集：

The EXP of the variable is: 2.69498e+164

FLOOR
返回小于或等于所给数字表达式的最大整数。

语法
FLOOR ( numeric_expression )

参数
numeric_expression

精确数字或近似数字数据类型类别的表达式（bit 数据类型除外）。

返回类型
返回与 numeric_expression 相同的类型。

示例
此示例说明正数、负数和货币值在 FLOOR 函数中的运用。

SELECT FLOOR(123.45), FLOOR(-123.45), FLOOR($123.45)

结果为与 numeric_expression 数据类型相同的计算值的整数部分。

--------- --------- -----------
123 -124 123.0000

LOG
返回给定 float 表达式的自然对数。

语法
LOG ( float_expression )

参数
float_expression

是 float 数据类型的表达式。

返回类型
float

示例
下例计算给定 float 表达式的 LOG。

DECLARE @var float
SET @var = 5.175643
SELECT 'The LOG of the variable is: ' + CONVERT(varchar,LOG(@var))
GO

下面是结果集：

The LOG of the variable is: 1.64396

LOG10
返回给定 float 表达式的以 10 为底的对数。

语法
LOG10 ( float_expression )

参数
float_expression

是 float 数据类型的表达式。

返回类型
float

示例
下例计算给定变量的 LOG10。

DECLARE @var float
SET @var = 145.175643
SELECT 'The LOG10 of the variable is: ' + CONVERT(varchar,LOG10(@var))
GO

下面是结果集：

The LOG10 of the variable is: 2.16189

POWER
返回给定表达式乘指定次方的值。

语法
POWER ( numeric_expression , y )

参数
numeric_expression

是精确数字或近似数字数据类型类别的表达式（bit 数据类型除外）。

y

numeric_expression 的次方。y 可以是精确数字或近似数字数据类型类别的表达式（bit 数据类型除外）。

返回类型
与 numeric_expression 相同。

示例
A. 使用 POWER 显示结果 0.0
本示例显示返回结果 0.0 的浮点下溢。

SELECT POWER(2.0, -100.0)
GO

下面是结果集：

------------------------------------------
0.0

ROUND
返回数字表达式并四舍五入为指定的长度或精度。

语法
ROUND ( numeric_expression , length [ , function ] )

参数
numeric_expression

精确数字或近似数字数据类型类别的表达式（bit 数据类型除外）。

length

是 numeric_expression 将要四舍五入的精度。length 必须是 tinyint、smallint 或int。当 length 为正数时，numeric_expression 四舍五入为 length 所指定的小数位数。当 length 为负数时，numeric_expression 则按 length 所指定的在小数点的左边四舍五入。

function

是要执行的操作类型。function 必须是 tinyint、smallint 或 int。如果省略 function 或 function 的值为 0（默认），numeric_expression 将四舍五入。当指定 0 以外的值时，将截断 numeric_expression。

返回类型
返回与 numeric_expression 相同的类型。

注释
ROUND 始终返回一个值。如果 length 是负数且大于小数点前的数字个数，ROUND 将返回 0。

SQRT
返回给定表达式的平方根。

语法
SQRT ( float_expression )

参数
float_expression

是 float 类型的表达式。

返回类型
float

示例
下例返回 1.00 到 10.00 之间的数字的平方根。

DECLARE @myvalue float
SET @myvalue = 1.00
WHILE @myvalue < 10.00
BEGIN
SELECT SQRT(@myvalue)
SELECT @myvalue = @myvalue + 1
END
GO


SQL字符串函数

LEFT
返回从字符串左边开始指定个数的字符。

语法
LEFT ( character_expression , integer_expression )

参数
character_expression

字符或二进制数据表达式。character_expression 可以是常量、变量或列。character_expression 必须是可以隐式地转换为 varchar 的数据类型。否则，请使用 CAST 函数显式转换 character_expression。

integer_expression

是正整数。如果 integer_expression 为负，则返回空字符串。

返回类型
varchar
LEN
返回给定字符串表达式的字符（而不是字节）个数，其中不包含尾随空格。

语法
LEN ( string_expression )

参数
string_expression

要计算的字符串表达式。

返回类型
int
LOWER
将大写字符数据转换为小写字符数据后返回字符表达式。

语法
LOWER ( character_expression )

参数
character_expression

是字符或二进制数据表达式。character_expression 可以是常量、变量或列。character_expression 必须是可以隐性转换为 varchar 的数据类型。否则，使用 CAST 显式转换 character_expression。

返回类型
varchar

LTRIM
删除起始空格后返回字符表达式。

语法
LTRIM ( character_expression )

参数
character_expression

是字符或二进制数据表达式。character_expression 可以是常量、变量或列。character_expression 必须是可以隐性转换为 varchar 的数据类型。否则，使用 CAST 显式转换 character_expression。

返回类型
varchar

REPLACE
用第三个表达式替换第一个字符串表达式中出现的所有第二个给定字符串表达式。

语法
REPLACE ( 'string_expression1' , 'string_expression2' , 'string_expression3' )

参数
'string_expression1'

待搜索的字符串表达式。string_expression1 可以是字符数据或二进制数据。

'string_expression2'

待查找的字符串表达式。string_expression2 可以是字符数据或二进制数据。

'string_expression3'

替换用的字符串表达式。string_expression3 可以是字符数据或二进制数据。

返回类型
如果 string_expression（1、2 或 3）是支持的字符数据类型之一，则返回字符数据。如果 string_expression（1、2 或 3）是支持的 binary 数据类型之一，则返回二进制数据。

示例
下例用 xxx 替换 abcdefghi 中的字符串 cde。

SELECT REPLACE('abcdefghicde','cde','xxx')
GO

REPLICATE
以指定的次数重复字符表达式。

语法
REPLICATE ( character_expression , integer_expression )

参数
character_expression

由字符数据组成的字母数字表达式。character_expression 可以是常量或变量，也可以是字符列或二进制数据列。

integer_expression

是正整数。如果 integer_expression 为负，则返回空字符串。

返回类型
varchar

character_expression 必须为可隐性转换为 varchar 的数据类型。否则，使用 CAST 函数显式转换 character_expression。

注释
兼容级别可能影响返回值。有关更多信息，请参见 sp_dbcmptlevel。

示例
A. 使用 REPLICATE
下例重复两遍每个作者的名字。

USE pubs
SELECT REPLICATE(au_fname, 2)
FROM authors
ORDER BY au_fname

REVERSE
返回字符表达式的反转。

语法
REVERSE ( character_expression )

参数
character_expression

由字符数据组成的表达式。character_expression 可以是常量、变量，也可以是字符或二进制数据的列。

返回类型
varchar

注释
character_expression 必须为可隐性转换为 varchar 的数据类型。否则，使用 CAST 显式转换 character_expression。

RIGHT
返回字符串中从右边开始指定个数的 integer_expression 字符。

语法
RIGHT ( character_expression , integer_expression )

参数
character_expression

由字符数据组成的表达式。character_expression 可以是常量、变量，也可以是字符或二进制数据的列。

integer_expression

是起始位置，用正整数表示。如果 integer_expression 是负数，则返回一个错误。

返回类型
varchar

character_expression 必须为可隐性转换为 varchar 的数据类型。否则，使用 CAST 显式转换 character_expression。
RTRIM
截断所有尾随空格后返回一个字符串。

语法
RTRIM ( character_expression )

参数
character_expression

由字符数据组成的表达式。character_expression 可以是常量、变量，也可以是字符或二进制数据的列。

返回类型
varchar

SPACE
返回由重复的空格组成的字符串。

语法
SPACE ( integer_expression )

参数
integer_expression

是表示空格个数的正整数。如果 integer_expression 为负，则返回空字符串。

返回类型
char
STR
由数字数据转换来的字符数据。

语法
STR ( float_expression [ , length [ , decimal ] ] )

参数
float_expression

是带小数点的近似数字 (float) 数据类型的表达式。不要在 STR 函数中将函数或子查询用作 float_expression。

length

是总长度，包括小数点、符号、数字或空格。默认值为 10。

decimal

是小数点右边的位数。

返回类型
char

注释
如果为 STR 提供 length 和 decimal 参数值，则这些值应该是正数。在默认情况下或者小数参数为 0 时，数字四舍五入为整数。指定长度应该大于或等于小数点前面的数字加上数字符号（若有）的长度。短的 float_expression 在指定长度内右对齐，长的 float_expression 则截断为指定的小数位数。例如，STR(12,10) 输出的结果是 12，在结果集内右对齐。而 STR(1223, 2) 则将结果集截断为 **。可以嵌套字符串函数。

说明 若要转换为 Unicode 数据，请在 CONVERT 或 CAST 转换函数内使用 STR。

STUFF
删除指定长度的字符并在指定的起始点插入另一组字符。

语法
STUFF ( character_expression , start , length , character_expression )

参数
character_expression

由字符数据组成的表达式。character_expression 可以是常量、变量，也可以是字符或二进制数据的列。

start

是一个整形值，指定删除和插入的开始位置。如果 start 或 length 是负数，则返回空字符串。如果 start 比第一个 character_expression 长，则返回空字符串。

length

是一个整数，指定要删除的字符数。如果 length 比第一个 character_expression 长，则最多删除到最后一个 character_expression 中的最后一个字符。

返回类型
如果 character_expression 是一个支持的字符数据类型，则返回字符数据。如果 character_expression 是一个支持的 binary 数据类型，则返回二进制数据。

注释
可以嵌套字符串函数。

示例
下例通过在第一个字符串 (abcdef) 中删除从第二个位置（字符 b）开始的三个字符，然后在删除的起始位置插入第二个字符串，创建并返回一个字符串。

SELECT STUFF('abcdef', 2, 3, 'ijklmn')
GO

下面是结果集：

---------
aijklmnef

SUBSTRING
返回字符、binary、text 或 image 表达式的一部分。有关可与该函数一起使用的有效 Microsoft? SQL Server? 数据类型的更多信息，请参见数据类型。

语法
SUBSTRING ( expression , start , length )

参数
expression

是字符串、二进制字符串、text、image、列或包含列的表达式。不要使用包含聚合函数的表达式。

start

是一个整数，指定子串的开始位置。

length

是一个整数，指定子串的长度（要返回的字符数或字节数）。

说明 由于在 text 数据上使用 SUBSTRING 时 start 和 length 指定字节数，因此 DBCS 数据（如日本汉字）可能导致在结果的开始或结束位置拆分字符。此行为与 READTEXT 处理 DBCS 的方式一致。然而，由于偶而会出现奇怪的结果，建议对 DBCS 字符使用 ntext 而非 text。

返回类型
如果 expression 是支持的字符数据类型，则返回字符数据。如果 expression 是支持的 binary 数据类型，则返回二进制数据。

返回字符串的类型与给定表达式的类型相同
UPPER
返回将小写字符数据转换为大写的字符表达式。

语法
UPPER ( character_expression )

参数
character_expression

由字符数据组成的表达式。character_expression 可以是常量、变量，也可以是字符或二进制数据的列。

返回类型
varchar

注释
character_expression 必须为可隐性转换为 varchar 的数据类型。否则请使用 CAST 函数显式转换 character_expression。


在SQL语句中使用参数

    为了使系统更灵活的适应各种应用，很多情况下可能需要使用SQL语句，在SQL语句中使用参数可以大大增强系统的灵活性，这样用户就可以在执行查询语句前，根据实际需要指定参数的值。

    【参数格式】

    系统要求在SQL语句中使用冒号(:)来标识一个参数，格式为　:<参数名称>　　例如：

                  :姓名

    参数名称可以使字母和汉字，，不要用运算符等特殊符号。以下是一个示例：

    SELECT * FROM 成绩信息表 WHERE 性别= :请输入性别

    这样的语句如果在节点上执行，系统会弹出一个默认的参数窗口：

    在编辑框中输入“男”，然后点击OK按钮，系统就会将所有男生的成绩信息列出。

    参数在SQL语句中的一些格式要求和获取参数值的方法随SQL语句的应用环境不同而有所不同，下面一一讲述。

    【信息树节点关联数据源中SQL语句参数】

    参数在SQL语句中设置时要考虑是使用系统默认的参数提示输入窗口还是自定义的参数输入窗口，两种方式对SQL语句参数的写法有所不同。

    使用系统默认的参数提示输入窗口：SQL语句参数不需要指定参数类型信息，例如：

            SELECT * FROM 成绩信息表 WHERE 性别= :请输入性别

    系统自动将参数做为字符串类型处理。也就是说，这种利用系统默认参数提示输入窗口的，仅仅适合于字符串参数。

    使用自定义参数窗口：SQL语句参数需要指定参数类型信息，例如：

            SELECT * FROM 成绩信息表 WHERE 性别= ':请输入性别'

            SELECT * FROM 学生信息 WHERE 年龄= :请输入年龄　(年龄为数值型，因此不需要引号)。

            SELECT * FROM 学生信息 WHERE 出生日期= #:请输入日期#　(出生日期为日期型，需要#括起，针对单机系统)

    【在触发器中的SQL语句参数】

    触发器中也可以使用参数，但是这里的参数并不从参数窗口获得用户输入的数值，而是直接从当前数据源的字段中获得，也就是说，参数名称只能是字段名称，例如：

insert into 进货汇总
select 进货明细.进货单号,sum(进货明细.应付金额) as 应付总额
from 进货明细
group by 进货明细.进货单号
having 进货明细.进货单号=:进货单号

    其中“进货单号”即为触发器当前信息源的字段名称，在语句执行时，系统自动将该字段的当前值替换该参数。

    触发器中的参数需要考虑参数类型问题，需要显示指定参数类型。

    【在SQL方式计算与验证设置窗口中的SQL语句参数】

    可以使用参数，这里的参数是直接从当前打开的数据源的字段中获得，也就是说，参数名称只能是字段名称，参数查找次序依次为：触发数据源－主表－从表。

    该除的参数需要考虑参数类型问题，需要显示指定参数类型。

    【在辅助录入设置中的SQL语句参数】

    辅助录入设置中的SQL语句参数也是字段参数，直接从数据源对应字段中取值，也需要考虑参数类型问题。

    【在运算树增强处理中的SQL语句参数】

    运算树中参数一般从运算树节点的参数列表中提供参数值的获取方法，如果没有提供，系统会在执行语句时弹出参数提示框。


创建系统文档

    创建系统文档用于为用户和开发者生成当前管理系统的内部设计信息，包括整个信息管理树每个节点的详细信息（数据源连接信息，主从表字段信息，主从表存储过程，记录筛选、字段筛选、批量计算、计算与验证，表格界面辅助录入设置信息，录入窗口辅助录入信息，报表设置信息，分析设置信息等），用户可以设定在生成的文档中包含上面的几种信息，而且可以设定是生成整个信息管理树的所有信息节点的信息，还是当前选定信息节点的信息。

    适用该窗口生成的文档为网页格式，可用浏览器查看，默认文件名为SysInfo.htm。

    【进入创建系统信息文档窗口】

    在主窗口，通过执行菜单：帮助－创建系统文档，即可进入创建系统文档窗口。

    【范围】

    指定生成的文档是包括所有信息节点还是当前选定的信息节点。

    【包括的信息内容】

    确定系统生成的文档中，具体包含每个信息节点的哪些详细信息，可以包括下面项目的任意组合或全部项目：数据源连接信息，主从表字段信息，主从表存储过程，记录筛选、字段筛选、批量计算、计算与验证，表格界面辅助录入设置信息，录入窗口辅助录入信息，报表设置信息，分析设置信息等。

    【开始创建按钮】

    系统根据设置生成当前系统的构成文档，生成的文件存放到指定的位置，为网页格式。


宏达电脑服务中心

    【专业的软件开发队伍】

    宏达电脑服务中心专门从事各行业管理软件的开发和推广，中心拥有一支精干、稳定的软件技术开发队伍，这支队伍不仅具有一流的专业素质和研发能力，丰富的系统开发经验，且具有良好的职业道德修养和综合分析技能。

    【丰富的产品线】

    宏达公司自主开发的《数据库信息管理开发平台》做为核心产品，在国内平台类产品中居于领先地位，操作简单，功能强大、容量小，对环境要求低，是真正的绿色软件构建平台。基于该平台开发的产品不计其数。拥有广泛的用户群体。

    公司已经开发了涵盖十几个行业的管理产品，满足各行业的实际管理需要。公司将逐步推出更多行业的管理产品，以更好的服务于各行业的管理应用。公司目前已经推出的产品参见：公司主要产品。

    【遍及全国的用户群体】

    “质量是企业的生命，顾客是生命的源泉”，宏达公司不断开发、完善宏达系列软件，严把质量关，用一流的软件回报用户，受到了用户的好评，宏达系列管理软件以其功能强大、操作简便、价格低廉的特性赢得了全国广大用户的青睐。目前用户已遍及全国所有省份、自治区、直辖市；用户遍及电子、电器、医药、服装、建筑、物资、化工、商贸、超市、旅游、机械、建材、科技、通讯等各类企业公司，同时拥有大量机关、事业单位、学校、研究所等机关事业型单位用户。

    【客户至上的公司理念】

    “出好产品，做好服务，提升客户价值！”

    产品是公司的根本，只有好的产品才能打动用户，宏达公司把开发好产品做为公司的第一原则；服务是软件应用的关键因素，有好的产品，只有在做好服务的前提下，才能够让用户真正的使用起来，宏达通过网络为用户提供全面的售前售后服务，并承诺为正版用户提供永久的免费升级服务，让用户用的放心，用的舒心；宏达公司所有的努力都是为了提高用户的价值，提高用户的效率和效益，公司存在的价值与公司为客户带来的价值成正比，宏达将一如既往的为提升客户价值而努力！

    【欢迎联系我们　共谋发展】

      公司位于美丽的“江北水城”聊城市，欢迎大家和我们联系，进行合作和发展！

      公司地址：山东省聊城市振兴西路18号楼
      聊城长途汽车站乘17路公交车振兴路与卫育路交叉路口向西100米（水城中学北邻）
      聊城火车站乘17路公交车育红小学东200米（水城中学北邻）
      电 话：0635-8386265、0635-8386255、0635-8961165、0635-8380716
      邮箱：hd-sc@hd-sc.com　 sale@hd-sc.com　 support@hd-sc.com


主要产品

    宏达公司已经推出了涵盖十几个行业的管理产品，受到用户的好评。以下是公司推出的一些主要产品,如果您的电脑已经连接到互联网，通过点击下面的系统名称，就可以下载相应系统的安装试用程序，并可以安装试用了！如果希望了解宏达更多的产品和产品的最新进展，请访问宏达管理软件服务在线网站（www.hdcsc.com）.

【开发工具】 | 【企业应用】 | 【房产物业】
数据库信息管理开发平台 | 商务进销存管理系统 | 房产销售管理系统V1.0
【交通运输】 | 人事管理系统 | 房产中介管理系统
车辆配件管理系统 | 设备管理系统 | 物业收费管理系统
车辆维修管理系统 | 库存管理系统 |
车辆贸易管理系统 | 办公事务管理系统 | 【教育应用】
车辆管理系统 | 工资管理系统 | 学校信息管理系统
电厂车辆管理系统 | 企业报表管理系统 | 学校收费管理系统
货运管理系统 | 店铺进销存管理系统 | 【其它】
【公安消防】 | 客户管理系统 | 有线电视收费管理系统
公安行政法律文书管理系统 | 空调安装维修管理系统 | 信访管理系统
公安刑事法律文书管理系统 | 固定资产管理系统 | 计划生育管理系统
公安机关档案管理系统 | 公文管理系统 | 环保执法文书管理系统
公安人员信息管理工作系统 | 销售管理系统 | 城管执法文书管理系统
公安派出所报警管理系统 | 采购管理系统 | ......
消防监督检查法律文书管理系统 | 精细库存管理系统 |
消防文书管理系统 | 摊位租赁管理系统 |
消防安全重点单位管理系统 | 餐饮管理系统 |
消防档案管理系统 | 派工管理系统 |
【健康医药】 | 家电维修管理系统 |
医院门诊收费管理系统 | 移动基站设备管理系统 |
医院门诊收费与住院管理系统 | 【合同系列】 |
医院管理系统 | 工业品买卖合同管理系统 |
国际疾病分类标准编码ICD-10查询系统 | 印刷合同管理系统 |
药店收费管理系统 | 商品代销合同管理系统 |
医疗机构监督执法文书管理系统 | 房屋租赁合同管理系统 |
卫生监督执法文书管理系统 | 经纪合同管理系统 |
中国法定传染病报告制作与统计管理系统 |  |
卫生行政许可文书管理系统 |  |


联系我们

    为保证用户更好的使用我们的产品，宏达公司为您提供网站服务、产品免费升级服务、电话技术支持服务、培训服务和在线问答等服务。

【网站服务】 | 公司建立了两个网站： 软件下载: http://www.it635.com 用户可以直接下载所有软件和资料。 服务在线：http://www.hdcsc.com 用户需在首页免费注册登录后，才可以获得全方位的服务：产品下载试用、技术文档、操作演示、技术论坛、留言、在线购买等。
【免费升级】 | 注册后提供最新、最完整光盘版本、免费升级、免费技术支持，终生售后服务，无限次地升级最新版本。产品升级后我们将最新版本发至您的邮箱，用户只需要将系统的同名文件履盖掉即可。
【电话支持】 | 产品分工负责，提供全方位电话支持： 技术：0635-8386255、8380716、8961165 销售：0635-8386265 传真：0635-8386265
【专门培训】 | 根据用户的需求情况。公司举行定期培训（收费），提高用户应用水平。
【在线问答】 | OICQ在线解答问题，快速、准确、及时： QQ群:3737605、7219075 加入QQ群，探讨宏达软件，有任何问题直接联系。 技术支持部QQ:121308329；销售部QQ:287251158、331396408 技术支持邮箱：support@hd-sc.com 销售服务邮箱：sale@hd-sc.com
【发货及时】 | 收到您汇款底单的传真当天即可特快专递发货。

    如果尊敬的用户您对我们有任何的不满意的地方，欢迎您拨通服务热线电话。　提出您宝贵的意见或建议，我们表示由衷的感谢!宏达公司为用户提供全面网络服务,支持就在您身边,产品应用无后顾之忧！

    【服务热线】 0635-8386255 8380716
    【服务邮箱】 support@hd-sc.com
    【传　　真】 0635-8386265


加盟合作

    随着宏达产品的用户越来越多，很多《数据库信息管理开发平台》用户利用平台开发了各种实用的管理系统，一些宏达管理系统的用户充分利用系统的二次开发功能，根据自身的实际管理需求改进了系统。在他们充分体验了宏达产品灵活、强大、开放的功能所带来的好处的同时，也希望将自己的成果和他人共享。同时有很多用户非常精通某一行业的管理业务和流程，但利用《数据库信息管理开发平台》开发产品有困难，又乐意将自已的管理经验奉献社会。

    为了满足大家的要求和更好的服务社会，同时有益于公司的发展，公司经过慎重考虑，决定以合作加盟的方式将用户的成果推向社会，同时也能获得相应的回报和提现自身的价值。

    根据用户成果的不同情况和合作意愿，合作方式分为如下几种：

用户情况 | 合作方式 | 备注
宏达公司《数据库信息管理开发平台》的非注册版用户，利用宏达公司《数据库信息管理开发平台》开发出信息库，系统涉及的管理内容和宏达现有产品不冲突，产品内容完整，基本上可以不做修正即可使用。 | 用宏达正版产品交换开发者信息库 | 交换后的宏达产品享受正版用户同样的待遇，享受免费升级、免费技术支持服务。 交换后的信息库文件所有权归宏达公司所有
宏达公司数据库信息管理开发平台》的非注册版用户。精通某一行业的管理业务和流程，有完整的开发思路和开发方向，或者已利用《数据库信息管理开发平台》开发出了一个雏形版本。具有一定通用价值，系统涉及的管理内容和宏达现有产品不冲突，双方可以合作开发。 | 可以和宏达公司合作共同开发完善该系统，系统以初级会员方式合作。 | 可以索取初级会员合作协议
宏达公司数据库信息管理开发平台》的注册版用户。精通某一行业的管理业务和流程，有完整的开发思路和开发方向，已利用《数据库信息管理开发平台》开发了某一行业实用的管理系统，该系统比较完善，具有一定通用价值，请将（*.dbi）文件、业务帮助（chm格式）和《系统使用指导手册》内容，发给我们，合作销售 | 可以和宏达公司合作共同开发完善该系统，合作销售，系统以高级会员方式合作。 | 可以索取高级会员合作协议
宏达公司的注册版用户，对宏达公司《数据库信息管理开发平台》及其它产品比较熟悉，并且期望能利用这个技能实现个人更大的价值。 | 可以为当地的宏达新用户提供增值服务，比如安装培训和基于宏达公司的产品进行二次开发等等。 | 必须获得宏达公司授权
 | 可以和宏达公司合作，为本地客户进行基于《数据库信息管理开发平台》的管理系统项目的开发。 | 根据不同情况可以采取多种合作方式

    欢迎大家合作加盟，合作发展，在获得相应报酬的同时，也提现了个人的价值，并为社会现代化管理的提高贡献一份力量。

    欢迎加盟宏达公司，携手共创宏图伟业！有意者请联系：
    单位名称：宏达电脑服务中心
    地　　址：山东省聊城市振兴西路18号楼
    联系电话：0635-8386265　8386255　8380716 8961165
    传　　真：0635-8386265
    邮　　箱：hd-sc@hd-sc.com　　club@hd-sc.com
    邮　　编：252000


产品注册

    【注册与非注册的区别】

    １、非注册版：网站下载的软件为非注册版本，为了让用户更多更好的了解我们的产品,您可以无期限的免费使用宏达的非注册版本，没有时间限制, 没有记录条数限制。只有报表的打印功能和少量的二次开发功能受限制。注册后免费升级、免费提供技术支持。如果您试用后感觉我们的产品符合您的管理需要，建议您购买注册版本。

    ２、注册版：非注册版用户试用满意后，通过购买，即可把非注册版数据平滑移植到注册版中。注册版本即是我们的销售版本，通过光盘发布，特快专递的方式将光盘、手册、发票、注册信息提供给用户。注册版本功能完整，没有任何限制，并可以获得完整的网络支持服务和永久的免费升级服务！

    【注册我们的产品】

    如果用户希望购买（注册）我们的产品，请参考下面的内容：

    一、获得产品价格：
      １、进入您试用的管理系统，执行软件菜单“系统→帮助→用户注册”，弹出 “感谢您作为一个注册用户！”窗口。窗口中有产品价格和汇款方式。
      ２、或请到我们宏达管理软件服务在线网站http://www.hdcsc.com查看！

    二、购买方式：

    １、依照宏达公司提供的产品价格和汇款方式办理付款手续。汇款方式请见下表，为了方便用户办理付款手续，除了提供公司账户汇款和邮政汇款外，还提供了各种银行卡汇款方式，用户可以根据自己的情况选用。

【公司账户汇款】 请到附近银行(最好是工商银行)办理付款手续。 开户行: 工行山东省聊城市振兴路支行 户名: 东昌府区宏达电脑服务中心 账号: 1611002309024814996 | 【邮局汇款】 请到附近邮局办理汇款手续 收款人地址: 山东聊城市振兴西路18号楼东区301室 收款人：杨继恩 邮编： 252000 | 【中国银行借记卡】 请携带个人身份到中国银行储蓄所办理 账号：6013 82600 800060 6998 收款人:吕克云
【中国工商银行牡丹灵通卡】 请携带个人身份证到工商银行储蓄所办理 账号：9558 8016 1110 0285843 户名：吕克云 | 【中国建设银行龙卡】 请携带个人身份证到建设银行储蓄所办理 账号：4367 4222 8230 1096 031 户名：杨继恩 | 【中国邮政储蓄绿卡】 请携带个人身份到邮政储蓄所办理 账号：955 10047 1000000 9194 收款人:吕克云
【中国农业银行卡】 请携带个人身份到中国银行储蓄所办理 账号：95599 8132 22985 16318 收款人：吕克云 |  |

    ２、款汇出后请及时将您购买软件的名称、单位名称、地址、邮政编码、联系人、邮箱、注册名称，及汇款凭据传真给我们，以便及时提供注册信息。我们收到传真后立即将光盘、手册、软件注册信息及发票通过特快专递的方式邮寄给您。如需当天获得软件注册码，我们会及时发到您的电子邮箱。

    ３、特快专递将在收到您的汇款或汇款凭据的传真（当天）办理，敬请查收！ 如果有其它情况，请和我们联系！

    联系电话：0635-8386265 8386255 8380716
    传真电话：0635-8386265
    电子邮箱：sale@hd-sc.com

    【在产品中输入注册信息】

    从开始菜单进入系统，执行主窗口菜单：帮助－用户注册，进入注册窗口。

    在“注册名称”栏输入宏达提供的注册名称，在“注册码”栏输入宏达公司提供的注册码，然后单击“注册”按钮。


信息表

    信息表也叫数据表，用来存储信息，以备查找、处理、分析和输出。信息通过录入或者导入到信息表中。合理规划和设计信息表的结构对于决定信息管理系统的质量好坏起很大作用。只有在对目标信息管理系统的功能需求做深入的了解和分析，才能设计出合适的信息表结构。

    本节主要讲述信息表相关的知识和操作。

    信息表基础知识

    设计信息表要用到信息表编辑器

    信息表通过信息管理树的信息节点来体现


基于信息单元的信息处理

    信息处理基本可以分为两种，基于信息单元的信息处理和基于整个信息管理系统的信息处理。前者包括：字段批量计算、记录计算与验证、序列填充、触发器和关联数据源时的SQL语句信息处理；后者主要是指“运算树信息增强处理”。

    本节主要说明基于信息单元的信息处理，这种处理一般都是和节点紧密相关的。